Closed Bug 1458385 Opened 2 years ago Closed 4 months ago

Repackage signed windows builds on linux.

Categories

(Firefox Build System :: Task Configuration, task)

3 Branch
task
Not set

Tracking

(firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: tomprince, Assigned: tomprince)

References

(Regression)

Details

Attachments

(7 files)

The repackaging step just runs mach and a couple of cross-platform tools. Thus, we can run it on linux, which cuts the time down from ~20m to <5m.
This only uses cross-platform tools, so switch to running these on linux, which
cuts the runtime down from ~20m to ~3m.
Attachment #8972468 - Flags: review?(mh+mozilla)
Comment on attachment 8972468 [details]
Bug 1458385: Repackage windows builds on linux. r=glandium,Callek

Mike Hommey [:glandium] has approved the revision.

https://phabricator.services.mozilla.com/D1080
Attachment #8972468 - Flags: review+
Comment on attachment 8972468 [details]
Bug 1458385: Repackage windows builds on linux. r=glandium,Callek

Flag set by Mike Hommey [:glandium] is no longer active.

https://phabricator.services.mozilla.com/D1080
Attachment #8972468 - Flags: review+
triaging and reassigning to :tomprince who wrote patches
Assignee: nobody → mozilla
Comment on attachment 8972468 [details]
Bug 1458385: Repackage windows builds on linux. r=glandium,Callek

This is not up for review again, right?
Attachment #8972468 - Flags: review?(mh+mozilla)
Version: Version 3 → 3 Branch
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/9a5f255979c2
Package mar and mbsdiff as a toolchain; r=glandium
https://hg.mozilla.org/integration/autoland/rev/99fa5539c2bd
Make linux64-upx toolchain tier 1; r=glandium
https://hg.mozilla.org/integration/autoland/rev/8036c03c3b51
Repackage windows builds on linux. r=glandium,Callek
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/262f6270009f
Port bug 1458385 - Repackage windows builds on linux. rs=bustage-fix
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4a172a403ce0
Backed out changeset 262f6270009f from C-C. a=backout

Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #9052335 - Attachment description: Bug 1458385: Make linux64-upx toolchain tier 1; r?glandium → Bug 1458385: Make linux64-upx toolchain tier 1; r=glandium
Attachment #9052334 - Attachment description: Bug 1458385: Package mar and mbsdiff as a toolchain; r?glandium → Bug 1458385: Package mar and mbsdiff as a toolchain; r=glandium

This matches the version that exists in mozilla-build (see Bug 1501403).

Attachment #8972468 - Attachment description: Bug 1458385: Repackage windows builds on linux. → Bug 1458385: Repackage windows builds on linux. r=glandium,Callek
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/3b10487587c3
Package mar and mbsdiff as a toolchain; r=glandium
https://hg.mozilla.org/integration/autoland/rev/cc06a7beb3d1
Make linux64-upx toolchain tier 1; r=glandium
https://hg.mozilla.org/integration/autoland/rev/f7791b680d46
Update linux-upx to 3.9.5; r=glandium
https://hg.mozilla.org/integration/autoland/rev/09338587b68e
Repackage windows builds on linux. r=glandium,Callek
Flags: needinfo?(mozilla)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d152954d3d35
Port bug 1458385 - Repackage windows builds on linux. rs=bustage-fix

Rob, the patch in comment #16 was a "quick fix" to get us going again. Please take a look. Also L10N failed on TB's Windows Nightly today, so this will need more work.

Flags: needinfo?(rob)
Status: RESOLVED → REOPENED
Flags: needinfo?(mozilla)
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---
Backout by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/89e6f1df09f4
Backed out changeset d152954d3d35 from C-C. a=backout DONTBUILD
Depends on: 1543662
Flags: needinfo?(rob)

Taskgraph needs to know the correct mar-channel, so allow it to pass it into the build,
rather than keying off the update-channel in configure. This will allow using a mar
binary that doesn't have the mar-channel configured in.

Rather than relying on the mar-channel-id set in the mar binary, set the channel
explicitly from taskcluster. This allows us to re-use the mar binary between
builds/channels.

Since the taskgraph knows the mar-channel-id to use, pass it explicitly to
the partial tasks, rather than extracting the channel from a MAR.

Attachment #9056310 - Attachment description: Bug 1458385: Update linux-upx to 3.9.5; r?glandium → Bug 1458385: Update linux-upx to 3.9.5; r=glandium
See Also: → 1564611
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/66f52bda7e14
Set mar-channel-id from taskcluster rather than based on update-channel; r=glandium
https://hg.mozilla.org/integration/autoland/rev/1be59290f02e
Generate MARs with the appropriate channel-id explicitly; r=nthomas
https://hg.mozilla.org/integration/autoland/rev/9d6fabede81c
[partials] Set the mar-channel-id of partials explicitly; r=sfraser
https://hg.mozilla.org/integration/autoland/rev/6fe86a878b81
Package mar and mbsdiff as a toolchain; r=glandium
https://hg.mozilla.org/integration/autoland/rev/f4439e9cad8d
Make linux64-upx toolchain tier 1; r=glandium
https://hg.mozilla.org/integration/autoland/rev/44487d4ee1b7
Update linux-upx to 3.9.5; r=glandium
https://hg.mozilla.org/integration/autoland/rev/11e9387ad7dc
Repackage windows builds on linux. r=glandium,Callek
Flags: needinfo?(mozilla)
Regressed by: 1577664
You need to log in before you can comment on or make changes to this bug.