Closed Bug 1458742 Opened 2 years ago Closed 2 years ago

Prefs docs should mention that input values are case-insensitive

Categories

(Testing :: Marionette, enhancement)

enhancement
Not set

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: ato, Assigned: ato)

Details

Attachments

(2 files)

"INFO", "iNfO", and "info" are all valid.
Assignee: nobody → ato
Status: NEW → ASSIGNED
Comment on attachment 8972742 [details]
Bug 1458742 - Correct marionette.log.level docs for case insensitivity.

https://reviewboard.mozilla.org/r/241274/#review247636
Attachment #8972742 - Flags: review?(mjzffr) → review+
Comment on attachment 8972743 [details]
Bug 1458742 - Add documentation for marionette.* prefs.

https://reviewboard.mozilla.org/r/241276/#review247638

::: testing/marionette/doc/Prefs.md:11
(Diff revision 1)
> +
> +
> +`marionette.enabled`
> +--------------------
> +
> +Starts and stops the Marionette server.  This will cause a TCP

Maybe explain how it relates to MOZ_MARIONETTE and --marionette? e.g. If I understand right, starting the browser with a profile that has marionette.enabled set to true is not enough to enable Marionette at start-up, you need to pass the --marionette flag as well. At least that's what my experiments with Fennec have shown me lately.
Attachment #8972743 - Flags: review?(mjzffr) → review+
Comment on attachment 8972743 [details]
Bug 1458742 - Add documentation for marionette.* prefs.

https://reviewboard.mozilla.org/r/241276/#review247638

> Maybe explain how it relates to MOZ_MARIONETTE and --marionette? e.g. If I understand right, starting the browser with a profile that has marionette.enabled set to true is not enough to enable Marionette at start-up, you need to pass the --marionette flag as well. At least that's what my experiments with Fennec have shown me lately.

Oh interesting.  I’m not sure if we should consider that a bug?

I will fix the documentation to call out the current behviour in any case.
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/169687fc666d
Correct marionette.log.level docs for case insensitivity. r=maja_zf
https://hg.mozilla.org/integration/autoland/rev/e8fb1c6b2597
Add documentation for marionette.* prefs. r=maja_zf
https://hg.mozilla.org/mozilla-central/rev/169687fc666d
https://hg.mozilla.org/mozilla-central/rev/e8fb1c6b2597
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
(In reply to Andreas Tolfsen ‹:ato› from comment #5)

> > Maybe explain how it relates to MOZ_MARIONETTE and --marionette?
> > e.g. If I understand right, starting the browser with a profile
> > that has marionette.enabled set to true is not enough to enable
> > Marionette at start-up, you need to pass the --marionette flag
> > as well. At least that's what my experiments with Fennec have
> > shown me lately.
>
> Oh interesting.  I’m not sure if we should consider that a bug?
>
> I will fix the documentation to call out the current behviour in
> any case.

If you after startup go to about:config and flip
marionette.enabled, the server _will_ start up however.
I think we should call this a bug and I’ve filed
https://bugzilla.mozilla.org/show_bug.cgi?id=1459414.
You need to log in before you can comment on or make changes to this bug.