Closed Bug 1458854 Opened Last year Closed Last year

release_eta for firefox rc build shouldn't be used for firefox-beta rule update

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox59 unaffected, firefox60 wontfix, firefox61 fixed, firefox62 fixed)

RESOLVED FIXED
Tracking Status
firefox59 --- unaffected
firefox60 --- wontfix
firefox61 --- fixed
firefox62 --- fixed

People

(Reporter: jcristau, Assigned: sfraser)

References

Details

(Keywords: regression)

Attachments

(1 file)

I started Firefox 60.0 build1 with ETA set to May 9 at 15:00 UTC (should have been 13:00 but nevermind).  That date was used for the scheduled change to the firefox-beta rule when pushing the RC build to beta.  That would previously (and I think should still) have been scheduled for "ASAP", only using the ETA for the actual firefox-release rule change.
Keywords: regression
Duplicate of this bug: 1458592
This should be in the release-secondary-balrog-scheduling task, ignoring release_eta and setting it blank
In essence, we're allowing a new field in the task definition,
which is trusted over the one that's passed in with the config. This
wouldn't make much sense if it had a real date in, but allows us to
set an empty string for the kind that needs it
Comment on attachment 8974045 [details]
Bug 1458854 Disable release_eta for rc on beta channel r=bhearsum

Ben Hearsum (:bhearsum) has approved the revision.

https://phabricator.services.mozilla.com/D1214
Attachment #8974045 - Flags: review+
Pushed by sfraser@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d95009513f9d
Disable release_eta for rc on beta channel r=bhearsum
https://hg.mozilla.org/mozilla-central/rev/d95009513f9d
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Assignee: nobody → sfraser
Blocks: 1460906
You need to log in before you can comment on or make changes to this bug.