Crash in mozilla::dom::WorkerPrivate::Control

VERIFIED FIXED in Firefox 61

Status

()

defect
P1
critical
VERIFIED FIXED
a year ago
9 months ago

People

(Reporter: calixte, Assigned: bkelly)

Tracking

(Blocks 1 bug, {crash, regression})

Trunk
mozilla61
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox59 unaffected, firefox60 unaffected, firefox61 verified)

Details

(crash signature)

Attachments

(1 attachment)

Reporter

Description

a year ago
This bug was filed from the Socorro interface and is
report bp-0ba465c1-200f-4d5a-9398-2a8b30180503.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::WorkerPrivate::Control dom/workers/WorkerPrivate.cpp:3540
1 xul.dll static bool mozilla::dom::`anonymous namespace'::ScriptExecutorRunnable::WorkerRun dom/workers/ScriptLoader.cpp:2086
2 xul.dll mozilla::dom::WorkerRunnable::Run dom/workers/WorkerRunnable.cpp:380
3 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1090
4 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:519
5 xul.dll mozilla::dom::WorkerPrivate::RunCurrentSyncLoop dom/workers/WorkerPrivate.cpp:4232
6 xul.dll static void mozilla::dom::`anonymous namespace'::LoadAllScripts dom/workers/ScriptLoader.cpp:2275
7 xul.dll mozilla::dom::workerinternals::LoadMainScript dom/workers/ScriptLoader.cpp:2397
8 xul.dll static bool mozilla::dom::`anonymous namespace'::CompileScriptRunnable::WorkerRun dom/workers/WorkerPrivate.cpp:438
9 xul.dll mozilla::dom::WorkerRunnable::Run dom/workers/WorkerRunnable.cpp:380

=============================================================

There are 4 crashes (from 3 installations) in nightly 61 with buildid 20180502220059. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1457157.

[1] https://hg.mozilla.org/mozilla-central/rev?node=c86679a9bf83
Flags: needinfo?(bkelly)
Andrea, I believe this is more fallout from setting mClientSource to nullptr when we hit Terminating.  Lets check for this in more places.

Note, I did not change GetClientState() because I think that should only ever be called when mClientSource exists.
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Flags: needinfo?(bkelly)
Attachment #8972971 - Flags: review?(amarchesini)
Priority: -- → P1
Attachment #8972971 - Flags: review?(amarchesini) → review+

Comment 2

a year ago
Pushed by bkelly@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/86d1e26507db
Avoid accessing mClientSource when a worker is Terminating in more places. r=baku

Comment 3

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/86d1e26507db
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.