Multiple "default mail client " problems

VERIFIED DUPLICATE of bug 141965

Status

VERIFIED DUPLICATE of bug 141965
17 years ago
14 years ago

People

(Reporter: arnova, Assigned: bugs)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

There are 3 issue's (one I reported earlier but it got status "not reproducable"):
1) From the messenger window (not navigator!): Preferences, "Mail & Newsgroups",
disable/enable "Use Mozilla as default mail application" doesn't get saved (if
changed) when pressed "OK"

2) When "Use Mozilla as default mail application" is reenabled(disable =>
enable) both the [HKEY_CLASSES_ROOT\mailto\shell\open\command] and the
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\shell\open\command] registry keys
are not rewritten with the "...\mozilla.exe -mail" value

3) At installation only the
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\shell\open\command] is written to
the registry and not the [HKEY_CLASSES_ROOT\mailto\shell\open\command]. This
causes most internet application NOT to use Mozilla as default mail client.

Reproducible: Always
Steps to Reproduce:
1.Install mozilla and register mail client as OS default mail client
2.Check both the [HKEY_CLASSES_ROOT\mailto\shell\open\command] and
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto\shell\open\command].
3. Remove both registry keys
4. First try to disable, enable "Mail & Newsgroups" from messenger. This doesn't
work (not saved).
5. Try the same thing from navigator => Now enable/disable are saved but:
6. Check both registry keys => they don't exist

Actual Results:  Mozilla is NOT the default mail client (again)

Expected Results:  Mozilla should be the default mail client.

Comment 1

16 years ago
Probably related to bug 141965, resolving as dupe.

*** This bug has been marked as a duplicate of 141965 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.