Closed Bug 1459044 Opened 2 years ago Closed 2 years ago

'Remove All Attachments' in Compose window hard to access if attachment list is full

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 707432

People

(Reporter: aryx, Unassigned)

References

Details

Bug 1428631 added a menu item 'Remove All Attachments' to the attachment list in the Compose window. The menu item only gets shown in the context menu if one right clicks on an area without attachment and there is none if the attachment list is full.

Steps to reproduce:
1. Open Compose Window.
2. Add 5+ attachments.
3. Right click with the mouse anywhere in the attachment pane to get the context menu.
Actual result: 'Remove All Attachments' not shown.
Expected result: 'Remove All Attachments' shown.
Flags: needinfo?(acelists)
The context menu you get on the blank space in the attachment bucket is different from the one you get on an attachment in the list. On the attachment there are also no "Attach *" items, or "Remind me later" item.

The menus are implemented separately, just some of the items are specified in both of them. E.g. "Reorder Attachments" is.

This would need UI discussion on how those context menus are intended to interact and which items should be shared in both of them. Is only "remove all attachments" to be had in both, or some more items?
Flags: needinfo?(richard.marti)
Flags: needinfo?(bugzilla2007)
Flags: needinfo?(acelists)
The 'Remove All Attachments' is not really needed as on the attachment is a 'Select All' and then we have the 'Remove Attachments' (spot the 's' at the end). This is a click more but I think removing all attachments isn't the most used function and the actual workflow makes sense to let apply the menu depending on the count of selected items.

What is missing is the 'Attach *' item with a full list. But this could be planned in bug 707432 or bug 1427092.
Flags: needinfo?(richard.marti)
I agree with Richard. Ux-consistency, ux-minimalism, ux-error-prevention: As in message reader's attachment pane, we want to show only a small number of commands immediately relevant  to the selection. Having *-all commands on selection context reduces the relative discoverability of selection commands and is error-prone (selection-contextual menu showing commands for another, bigger selection, which is a very different context). In the bugs mentioned by Richard, we'll add the list context menu to the "3 attachments" header (which represents all attachments), so it will always be available. If we succeed to move the Attach button to the right, Remove-all may also be added to the drop-down of that button.

We used to ensure vertical whitespace below the list of attachments, which got lost or removed. I'd love to see that return, but we want to avoid showing scroll bars when there's nothing to scroll for. Maybe CSS and/or JS or XUL hack can accomplish this. Richard?
Flags: needinfo?(bugzilla2007) → needinfo?(richard.marti)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Summary: 'Remove All Attachments' in Compose window not shown if attachment list full → 'Remove All Attachments' in Compose window hard to access if attachment list is full
Duplicate of bug: 707432
Without scrollbar isn't possible. The sanest version would be:

#attachmentBucket > attachmentitem:last-child {
  margin-bottom: 5px;
}

But also this would add the scrollbar when the bucket has the exact height of all attachment items because of the added 5 px.
Flags: needinfo?(richard.marti)
You need to log in before you can comment on or make changes to this bug.