If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

.exe is appended to attachment names

VERIFIED DUPLICATE of bug 120327

Status

MailNews Core
Attachments
VERIFIED DUPLICATE of bug 120327
16 years ago
9 years ago

People

(Reporter: Dietmar Hauser, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When trying to save an attachment with an unknown file ending (in my case ".ace" and ".Log", but 
".foo" or ".xxx" should produce the same behavior) by doubleclicking it, Mozilla Mailer (Build 
20020510) appends ".exe" to the proposed filename, makeing it look like a "virus".
This does 
not happen when saving the attachment via Right Click + Save as... and only seems to happen with 
attachments of content type "application/octet-stream" (which is wrong, but non the less 
produced by most other mailing clients...).

To reproduce:
1. Have an email with an unknown 
attachment type sent to you. Make sure that is sent with content-type "application/octet-stream" 
(easily achieved by using a foreign mailer like opera or outlook).
2. Try to save the attachment 
by double clicking on it.

Mozilla will add ".exe" to the filename, thus turning "foo.xxx" 
into "foo.xxx.exe".

Comment 1

16 years ago
Is that a dup of bug 120327 ??
(Reporter)

Comment 2

16 years ago
Apparently...
Sorry for posting it a second time, but I was unable to find it when I looked for 
it.
But honestly, I didn't really know how to search for such a bug ;)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 120327 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified dupe
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.