Open Bug 1459217 Opened 2 years ago Updated 2 years ago

Visual glitches occur on Html videos

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox60 --- wontfix
firefox61 --- fix-optional
firefox62 --- fix-optional

People

(Reporter: Anca, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]: 
- 61.0b2 dev edition
- 61.0a1 (2018-05-04)

[Affected platforms]:
- macOS 10.13
- Mac OS 10.12
- Windows 10 x64

[Steps to reproduce]:
1. Launch Firefox
2. Set the layers.acceleration.disabled to true in about:config
3. Open this link: http://html5doctor.com/demos/video-canvas-magic/demo0.html 
4. Click on the Play button on the video

[Expected result]:
- No glitches are displayed when playing the video.

[Actual result]:
- Visual glitches are triggered when the Play button is clicked. This occurs every time the page is refreshed

[Regression range]:
- I will try to find one asp.

[Additional notes]:
- Note that the macOS 10.13 seems to be more affected by this behaviour, on the other platform affected, mentioned above, the glitches can be seen only around the Play button.
Summary: Summary: [Skia] Visual glitches occur on Html videos → [Skia] Visual glitches occur on Html videos
Component: Audio/Video → Audio/Video: Playback
I tried to find a regression, both manually and by using mozregresssion. On older builds, I could only observed glitches on macOS 10.13. This issue was still reproducible on Firefox 51.0a1 (2016-09-01), but not on Firefox 32.0a1 (2014-05-21)  Between this two dates I couldn’t open the required builds in order to determine exactly what triggers this behavior. Not sure if this inconvenient  is caused by the builds in question or has something to do with the two machines I’ve tested.
Anca, you put Skia in the title here. Have you already confirmed that this is due to skia somehow? Should I move this to Graphics already, or do you have reason to believe this is an A/V issue?
Flags: needinfo?(anca.soncutean)
After further investigation on the latest nightly and latest beta builds on mac platforms, indeed this behavior is not necessary related to Skia. On Firefox 63.0a1 (2018-06-25), I could see the glitches only when layers.acceleration.disabled was set on true, but on Firefox 62.0b3, the glitches are noticeable, regardless the pref setting, but note that, the glitches are definitely more intense when layers.acceleration.disabled is set on true.
Flags: needinfo?(anca.soncutean)
I am not able to reproduce on a 2016 Macbook Pro running Mac OS 10.13.5 with june 21st Nightly. Both on integrated and dedicated gpus.

Do you think you could record a video showing the glitch? Thanks!
Flags: needinfo?(anca.soncutean)
Summary: [Skia] Visual glitches occur on Html videos → Visual glitches occur on Html videos
This is a screencast made on Firefox 62.0b3, on iMac 2013, version macOS 10.13.4, graphics Intel Iris Pro 1536, with the pref layers.acceleration.disabled set on true.
Flags: needinfo?(anca.soncutean)
Thanks! That looks like a graphics issue to me so moving to that component for further triage.
Component: Audio/Video: Playback → Graphics
You need to log in before you can comment on or make changes to this bug.