Closed Bug 1459285 Opened 2 years ago Closed 2 years ago

Update to tzdata2018e

Categories

(Core :: JavaScript: Internationalization API, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr52 61+ fixed
firefox-esr60 61+ fixed
firefox60 --- wontfix
firefox61 + fixed
firefox62 + fixed

People

(Reporter: anba, Assigned: anba)

Details

Attachments

(3 files, 1 obsolete file)

Attached patch bug1459285.patch (obsolete) — Splinter Review
(I think ICU is still using the so called "rearguard" format which doesn't use negative DST values. Well, at least I hope they do...)

Apart from negative DST changes for the now default "vanguard" format, this tzdata update only changes North Korea's time zone.
Attachment #8973301 - Flags: review?(jwalden+bmo)
Comment on attachment 8973301 [details] [diff] [review]
bug1459285.patch

(In reply to André Bargull [:anba] from comment #1)
> (I think ICU is still using the so called "rearguard" format which doesn't
> use negative DST values. Well, at least I hope they do...)

Or not -> https://ssl.icu-project.org/trac/changeset/41324 

Which means the patch here needs to be updated, too. Clearing review for now.
Attachment #8973301 - Flags: review?(jwalden+bmo)
Attached patch bug1459285.patchSplinter Review
Updated patch which doesn't include the negative DST rules for Europe/Prague.
Attachment #8973301 - Attachment is obsolete: true
Attachment #8974292 - Flags: review?(jwalden+bmo)
Attachment #8974292 - Flags: review?(jwalden+bmo) → review+
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/757d7a7bed0c
Update tzdata in ICU data files to 2018e. r=Waldo
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/757d7a7bed0c
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Is this something we need to backport to all the branches?
Flags: needinfo?(andrebargull)
Yes, I've planned to add backports for the other branches.
Backport for ESR52 (different patch needed because ESR52 uses ICU58).
Attachment #8975548 - Flags: review?(jwalden+bmo)
Backport for ESR60 (different patch needed because ESR60 uses ICU60).
Attachment #8975549 - Flags: review?(jwalden+bmo)
Attachment #8975548 - Flags: review?(jwalden+bmo) → review+
Attachment #8975549 - Flags: review?(jwalden+bmo) → review+
Comment on attachment 8974292 [details] [diff] [review]
bug1459285.patch

Approval Request Comment
[Feature/Bug causing the regression]:
N/A

[User impact if declined]:
Wrong or inconsistent time zone data when calling methods from Intl.DateTimeFormat or methods internally using Intl.DateTimeFormat (that means Date.prototype.toLocale(Date|Time)String()). Inconsistencies are possible when the OS already uses the current tzdata release (tzdata 2018e), but our internal ICU version still uses tzdata 2018d. 

[Is this code covered by automated tests?]:
Yes.

[Has the fix been verified in Nightly?]:
Yes.

[Needs manual test from QE? If yes, steps to reproduce]: 
No.

[List of other uplifts needed for the feature/fix]:
None.

[Is the change risky?]:
No.

[Why is the change risky/not risky?]:
It only updates time zone data files.

[String changes made/needed]:
No.
Flags: needinfo?(andrebargull)
Attachment #8974292 - Flags: approval-mozilla-beta?
Comment on attachment 8975549 [details] [diff] [review]
bug1459285-esr60.patch

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:

User impact if declined: 
See comment #11.

Fix Landed on Version:
Firefox 62; Firefox 61 see comment #11.

Risk to taking this patch (and alternatives if risky): 
See comment #11.

String or UUID changes made by this patch: 
No.
Attachment #8975549 - Flags: approval-mozilla-esr60?
Comment on attachment 8975548 [details] [diff] [review]
bug1459285-esr52.patch

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:

User impact if declined: 
See comment #11.

Fix Landed on Version:
Firefox 62; Firefox 61 see comment #11.

Risk to taking this patch (and alternatives if risky): 
See comment #11.

String or UUID changes made by this patch: 
No.
Attachment #8975548 - Flags: approval-mozilla-esr52?
Comment on attachment 8974292 [details] [diff] [review]
bug1459285.patch

Gotta keep our timezone data up to date. Approved for 61.0b6.
Attachment #8974292 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8975548 [details] [diff] [review]
bug1459285-esr52.patch

tzdata update for 52.9esr
Attachment #8975548 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
Comment on attachment 8975549 [details] [diff] [review]
bug1459285-esr60.patch

tzdata update for 60.1esr
Attachment #8975549 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.