Scrolling impossible; see description

RESOLVED DUPLICATE of bug 161365

Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 161365
16 years ago
13 years ago

People

(Reporter: Peter Deisz, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; de-AT; rv:1.0rc2) Gecko/20020510
BuildID:    2002051005

System.9.1, iBook (snow) 500 MHz, 380 MB-RAM
Doesn't scroll with arrows nor with margin-handlers

Reproducible: Always
Steps to Reproduce:
1.Window closed
2.new Window with new download
3.reloaded

Actual Results:  same result

Expected Results:  scroll the page

cookies not allowed
Looks like bug 100547

Comment 2

16 years ago
WorksForMe using Mac/2002072203. Scrolling functions using any method of scrollbar control, 
though there are some visual problems. Peter, can you still reproduce this problem using a 
current build? If so, can you reproduce this problem using a new Mozilla user profile?

Comment 3

16 years ago
I do have the same kind of problem under Mac OS X, with Mozilla 1.1. Everything
is working fine with 1.1a. Scrolling with the arrows became very slow, to slow
with Mozilla 1.1b. I had to click on the very middle of each arrow to be able to
have a normal crolling with 1.1b. Clicking away from the center of the arrow was
just scrolling 1 or 2 lines.... 
Scrolling with scrollbar arrows became impossible since 1.1 release. Arrows
aren't responding anymore... Moving the scrollbar widget or scrolling by
clicking over or below the scrollbar widget is working fine. 
I will try to create a new profile and then post you my results.

Mouse : Apple Mouse Pro
System : Mac OS X 10.1.5 + Mac OS X 10.2

Comment 4

16 years ago
Bruno, you encountered two different bugs. The former is bug 157837, the latter bug 161365.

Comment 5

16 years ago
Thank you Greg. 
I found a solution available under Mac OS X 10.1.5 and 10.2 :
1) 
- deleting each Mozilla preference files (4 files, I guess, if your are testing
Mozilla since monthes...) from ~/Library/Preferences/ can help.
- launch Mozilla to check.

2) if this wasn't sufficient:
- quit Mozilla
- delete any Mozilla preference file found inside ~/Library/Preferences/ - one
or two preferences files should have been created when Mozilla was launched
after step 1).
- Move the folder found inside ~/Library/Mozilla/nameoftheprofile/
(nameoftheprofile will be "default" by default. But different if you had
previously used "Mozilla Profile Manager" to create your profile). Move this
folder outside from ~/Library/Mozilla/nameoftheprofile/ folder;
- erase the now empty folder ~/Library/Mozilla/nameoftheprofile/
- Double-click "Mozilla Profile Manager" (you will find that file inside
"Mozilla" application's folder)
- Create a new profile;
- use the "Exit" button;
- you will find a folder inside ~/Library/Mozilla/nameofthenewprofile/ .The name
of this folder is ending with ".slt" (like the previously moved folder's name).
 Copy the name of this folder;
- erase this folder.
- rename the moved folder by pasting the name of the deleted one;
- move the renamed folder inside ~/Library/Mozilla/nameofthenewprofile/
- launch Mozilla.
Then everything should work again...
Restauring a profile isn't a pleasure... Profile importation would be welcome in
a next release ;)

Peter, under Mac OS 9.x a same method could probably give the same good result.
Delete every mozilla preferences files found inside /System Folder/Preferences/
 to begin. Then if this wasn't sufficient try the part 2).

Bruno

Comment 6

16 years ago
Dup

*** This bug has been marked as a duplicate of 161365 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.