Closed Bug 1459515 Opened 2 years ago Closed 2 years ago

remove CRLF line endings in /mail files

Categories

(MailNews Core :: General, enhancement, trivial)

enhancement
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 61.0

People

(Reporter: aceman, Assigned: aceman)

Details

Attachments

(2 files)

There are some remaining files in c-c that have Windows (CRLF) line endings, while the style is to use only LF (Linux) line endings.

This does not include .eml files in tests.
Attached patch 1459515.patchSplinter Review
Attachment #8973563 - Flags: review?(jorgk)
Attached patch 1459515-SM.patchSplinter Review
Attachment #8973564 - Flags: review?(frgrahl)
Product: Thunderbird → MailNews Core
Target Milestone: --- → Thunderbird 61.0
Comment on attachment 8973564 [details] [diff] [review]
1459515-SM.patch

LGTM.

Could you ask IanN for beta approval. esr cycle is just starting and we still need to do some extensive patches for esr60. Less rebasing in case these files are touched.
Attachment #8973564 - Flags: review?(frgrahl) → review+
Comment on attachment 8973564 [details] [diff] [review]
1459515-SM.patch

Sure, thanks.

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: esr cycle is just starting and we still
need to do some extensive patches for esr60. Less rebasing in case these files
are touched.
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): probably none
Attachment #8973564 - Flags: approval-comm-beta?
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9c5f2c43407d
replace CRLF line endings with LF - Thunderbird. r=jorgk
https://hg.mozilla.org/comm-central/rev/a12da8ac846a
replace CRLF line endings with LF - Seamonkey. r=frg
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Comment on attachment 8973564 [details] [diff] [review]
1459515-SM.patch

No one ever approved this, the TB part wasn't uplifted, so let's forget about it.
Attachment #8973564 - Flags: approval-comm-beta?
You need to log in before you can comment on or make changes to this bug.