Wrong DNS lookup after DNS server address has been changed

RESOLVED DUPLICATE of bug 64857

Status

()

Core
Networking
--
major
RESOLVED DUPLICATE of bug 64857
16 years ago
16 years ago

People

(Reporter: Takahide HIGUCHI, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Since I'm using mozilla on linux laptops, /etc/resolv.conf is often changed by
getting DHCP leases from different networks. Since Mozilla seems to cache IP
address of DNS server only at boot time, Mozilla can't resolve URLs after such
an update of /etc/resolv.conf if the cached DNS server address is not reachable.
 
For example, If I boot mozilla at my office, DNS server address, which is
192.168.1.1, is cached. When I go home, or go to conference room with wireless
LAN card, my laptop gets new DHCP lease but Mozilla does not update cached DNS
server address. If 192.168.1.1 is not reachable from there, Mozilla no longer
resolve URLs and I have to restart it.
Dupe of bug 64857

*** This bug has been marked as a duplicate of 64857 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.