Firefox executables properties show ../../dist/bin/… as Original filename

RESOLVED FIXED in Firefox 61

Status

defect
--
trivial
RESOLVED FIXED
Last year
Last year

People

(Reporter: rnair, Assigned: ted)

Tracking

({in-triage, regression})

61 Branch
mozilla62
All
Windows
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox60 unaffected, firefox61 fixed, firefox62 fixed)

Details

Attachments

(3 attachments)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180503152818

Steps to reproduce:

The Firefox Developer version shows invalid file name. From the Firefox properties the Original filename shows like this  "../../dist/bin/firefox.exe" 




Expected results:

The Original file name should be Firefox.exe
:Gijs, a little help please. If I click the Component drop-down box here, Build Config is missing from both Firefox and Core. Is that normal — does moving and filing reports there require special privileges?

crashreporter.exe
../../../dist/bin/crashreporter.exe

firefox.exe
../../dist/bin/firefox.exe

maintenanceservice.exe
../../../dist/bin/maintenanceservice.exe

maintenanceservice_installer.exe
maintenanceservice_installer.exe
^ this one's OK!

minidump-analyzer.exe
../../../dist/bin/minidump-analyzer.exe

pingsender.exe
../../../../dist/bin/pingsender.exe

plugin-container.exe
../../dist/bin/plugin-container.exe

plugin-hang-ui.exe
../../../../dist/bin/plugin-hang-ui.exe

updater.exe
../../../../dist/bin/updater.exe
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → Windows
Hardware: Unspecified → All
Summary: Invalid Original file name. → Firefox executables properties show ../../dist/bin/… as Original filename
I think the build stuff moved to its own product...
Component: Untriaged → General
Product: Firefox → Firefox Build System
Almost certainly a regression from bug 1255485. I don't think this is harmful, it's just for display.

Looks like we could just wrap the argument to `-BINARY` in `$(notdir)` here:
https://dxr.mozilla.org/mozilla-central/rev/2d95d70298e248161b629ef1d0d57049c0b62d71/config/version.mk#25
Depends on: 1255485
Keywords: in-triage
Assignee: nobody → ted
The original filename looks sensible in my local build with this patch.
We should be able to uplift this to beta once it lands, it's a trivial patch and bug 1255485 is on beta.
Attachment #8975069 - Flags: review?(core-build-config-reviews) → review?(cmanchester)
Comment on attachment 8975069 [details]
bug 1459597 - fix Original Filename display in Windows file version info.

https://reviewboard.mozilla.org/r/243412/#review249794
Attachment #8975069 - Flags: review?(cmanchester) → review+
Pushed by tmielczarek@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bad54bae22fa
fix Original Filename display in Windows file version info. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/bad54bae22fa
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Please request Beta approval on this when you get a chance. No point in shipping this regression for a release when it's easily avoidable.
Flags: needinfo?(ted)
Comment on attachment 8975069 [details]
bug 1459597 - fix Original Filename display in Windows file version info.

Approval Request Comment
[Feature/Bug causing the regression]: bug 
1255485 
[User impact if declined]: Minor cosmetic ugliness in the Windows Explorer file Properties dialog's "Detail" pane.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]:  No
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: Changes a string that is embedded in the file's resource section but is not used for anything else.
[String changes made/needed]: N/A
Flags: needinfo?(ted)
Attachment #8975069 - Flags: approval-mozilla-beta?
Comment on attachment 8975069 [details]
bug 1459597 - fix Original Filename display in Windows file version info.

Fixes a cosmetic bug in Windows Explorer introduced in Fx61. Approved for 61.0b7.
Attachment #8975069 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.