Closed Bug 1459636 Opened 3 years ago Closed 2 years ago

Entering fullscreen with double click on twitch streams does not work

Categories

(Core :: Audio/Video: Playback, defect, P2)

61 Branch
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr60 --- unaffected
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected

People

(Reporter: cbaica, Unassigned)

Details

Attachments

(1 file)

Attached video fullscreen bug
[Affected versions]:
Firefox 61.0b2 devEdtion, Firefox 60.0b16, Firefox 60.0RC

[Unaffected versions]:
Firefox 60 ESR

[Affected platforms]:
Windows 10 x64, macOS 10.13.5, Ubuntu 16.04 x64, Windows 7 x64

[Steps to reproduce]:
1.Launch Firefox.
2.Enter https://www.twitch.tv/.
3.Start a video livestream.
4.Double click on the video to enter fullscreen mode.

[Expected result]:
The video enters fullscreen mode.

[Actual result]:
The video is not entering fullscreen mode (though the fullscreen indicator changes its state).

This error is thrown in the browser console: Request for fullscreen was denied because Element.requestFullscreen() was not called from inside a short running user-generated event handler.

[Regression range]:
I tried to find a regression, but the issue is reproducible on Firefox 37.0a1 (2014-11-29) and on older version of Firefox can't load Twitch streams.

[Additional notes]:
Since I haven't found any regression for this issue, it might be related to Bug 1441881 since the received console error is similar.
I'm not able to repro with 60 or 62 on my Mac.
Rank: 15
Priority: -- → P2
Probably a dupe of bug 1436474?
Apparently not a dupe, the bug was fixed at some point and now is back again (with 60.0.2 the problem came back now, or even a previous version).
62.0a1 also affected.
Yes, bug 1436474 was exactly the same issue, though I don't know if now for the same technical reasons.

Ok this is interesting, in Chrome browser, for comparison, the exact same problem currently exists... Though, it doesn't affect it as badly as FF, since in current Chrome version one can fullscreen the Twitch player with keyboard button "f" and close fullscreen again fine (which basically just is a workaround in Chrome).
Okay after doing Windows Wpdate ("adobe flash update" it said or so) I am unable to reproduce, issue seems fixed for me. :)
(and after rebooting PC)
Still (or again, I actually think) an issue with FF 61.0.1 and Nightly. in 1080p streams (VODs work fine, no issue there) it happens. Nothing happening on double click left mousebutton. Example (this should be online 24/7): https://www.twitch.tv/monstercat And yes, might be related to bug 143674 .
Can't reproduce this issue on Nightly 63.0a1 (2018-08-21) in my OSX.
Still happening on Firefox 62.0.2 on Windows 10 1803 x64.
When the stream for some reason displays this extension overlay on the stream: https://i.postimg.cc/KjqWb4mS/Twitch_Bug.jpg

from this extension: https://www.twitch.tv/ext/d4uvtfdr04uq6raoenvj7m86gdk16v-2.0.17

When disabling it in the overlay down here (center bottom of stream window) it works fine again: https://i.postimg.cc/FHZS6kvD/Twitch_Bug2.jpg 

Problem is, user has to disable it everytime he restarts the browser... Same bug in Nightly 64.0a1
Flags: needinfo?(drno)
Flags: needinfo?(alwu)
Forgot to end my 2nd sentence: "When the stream for some reason displays this extension overlay on the stream, the user is unable to go into fullscreen by doubleclicking into the stream window or by pressing "F" for fullscreen"
Ok, I can reproduce this issue on Win 10, but it's a Twitch's issue, not Firefox's. 

It seems the additional overlay doesn't propagate the "click" event to the element under itself. This issue also exists on Chrome.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(drno)
Flags: needinfo?(alwu)
Resolution: --- → INVALID
"This issue also exists on Chrome." thanks for clarifying :)
You need to log in before you can comment on or make changes to this bug.