Closed Bug 1459766 Opened 2 years ago Closed 2 years ago

Crash in nsTArrayInfallibleAllocator::ResultTypeProxy nsTArray_base<T>::SwapArrayElements<T> | RetainedDisplayListBuilder::MergeDisplayLists

Categories

(Core :: Web Painting, defect, critical)

61 Branch
Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1457136
Tracking Status
firefox60 --- unaffected
firefox61 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-fba7bfe0-d6a5-4f95-8593-029920180506.
=============================================================

Seen while looking at crash stats - Mac and Linux crash which shows up in 61 nightly and 61b1: https://bit.ly/2HZVj8t. Mac crashes are all 10.13.

We seem to had a similar signature back in the 59 time frame: Bug 1419546. ni on :mattwoodrow since I believe he works in this area.

Top 10 frames of crashing thread:

0 XUL nsTArrayInfallibleAllocator::ResultTypeProxy nsTArray_base<nsTArrayInfallibleAllocator, nsTArray_CopyWithMemutils>::SwapArrayElements<nsTArrayInfallibleAllocator, nsTArrayInfallibleAllocator> xpcom/ds/nsTArray.h:476
1 XUL RetainedDisplayListBuilder::MergeDisplayLists xpcom/ds/nsTArray.h:1863
2 XUL MergeState::ProcessItemFromNewList layout/painting/RetainedDisplayListBuilder.cpp:279
3 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:487
4 XUL MergeState::ProcessItemFromNewList layout/painting/RetainedDisplayListBuilder.cpp:279
5 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:487
6 XUL MergeState::ProcessItemFromNewList layout/painting/RetainedDisplayListBuilder.cpp:279
7 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:487
8 XUL MergeState::ProcessItemFromNewList layout/painting/RetainedDisplayListBuilder.cpp:279
9 XUL RetainedDisplayListBuilder::MergeDisplayLists layout/painting/RetainedDisplayListBuilder.cpp:487

=============================================================
Flags: needinfo?(matt.woodrow)
Is this a duplicate of bug 1457136?
Flags: needinfo?(matt.woodrow)
(In reply to Matt Woodrow (:mattwoodrow) from comment #1)
> Is this a duplicate of bug 1457136?

Yes, sorry that bug didn't come up when I filed it, but this looks to be the Mac and Linux equivalent of that bug.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1457136
You need to log in before you can comment on or make changes to this bug.