Intermittent failure - browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 0 in nav-bar should match expectations. - Got forward-button, expected back-button

RESOLVED FIXED in Firefox 62

Status

()

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: intermittent-bug-filer, Assigned: Gijs)

Tracking

({intermittent-failure})

unspecified
Firefox 62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

(Whiteboard: [retriggered][stockwell fixed:timing])

Assignee

Updated

Last year
Summary: Intermittent browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 0 in nav-bar should match expectations. - Got forward-button, expected back-button → Intermittent TV (Verify) failure - browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 0 in nav-bar should match expectations. - Got forward-button, expected back-button
:Gijs tie1 failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=177591230&repo=autoland&lineNumber=4362

02:33:26     INFO -  1109 INFO TEST-START | browser/components/customizableui/test/browser_allow_dragging_removable_false.js
02:33:26     INFO -  TEST-INFO | started process screenshot
02:33:26     INFO -  TEST-INFO | screenshot: exit 0
02:33:26     INFO -  Buffered messages logged at 02:33:26
02:33:26     INFO -  1110 INFO Entering test bound
02:33:26     INFO -  1111 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | forward-button should not be removable -
02:33:26     INFO -  1112 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Should start in default state. -
02:33:26     INFO -  1113 INFO Actual placements: forward-button, back-button, stop-reload-button, home-button, customizableui-special-spring1, urlbar-container, customizableui-special-spring2, downloads-button, library-button, sidebar-button
02:33:26     INFO -  1114 INFO Expected placements: back-button, stop-reload-button, home-button, customizableui-special-spring1, forward-button, urlbar-container, customizableui-special-spring2, downloads-button, library-button, sidebar-button
02:33:26     INFO -  1115 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Area nav-bar should have 10 items. -
02:33:26     INFO -  Buffered messages finished
02:33:26    ERROR -  1116 INFO TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 0 in nav-bar should match expectations. - Got forward-button, expected back-button
02:33:26     INFO -  Stack trace:
02:33:26     INFO -  chrome://mochikit/content/browser-test.js:test_is:1290
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:placementArraysEqual:143
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:assertAreaPlacements:132
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/browser_allow_dragging_removable_false.js:null:17
02:33:26     INFO -  Not taking screenshot here: see the one that was previously logged
02:33:26    ERROR -  1117 INFO TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 1 in nav-bar should match expectations. - Got back-button, expected stop-reload-button
02:33:26     INFO -  Stack trace:
02:33:26     INFO -  chrome://mochikit/content/browser-test.js:test_is:1290
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:placementArraysEqual:143
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:assertAreaPlacements:132
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/browser_allow_dragging_removable_false.js:null:17
02:33:26     INFO -  Not taking screenshot here: see the one that was previously logged
02:33:26    ERROR -  1118 INFO TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 2 in nav-bar should match expectations. - Got stop-reload-button, expected home-button
02:33:26     INFO -  Stack trace:
02:33:26     INFO -  chrome://mochikit/content/browser-test.js:test_is:1290
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:placementArraysEqual:143
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:assertAreaPlacements:132
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/browser_allow_dragging_removable_false.js:null:17
02:33:26     INFO -  Not taking screenshot here: see the one that was previously logged
02:33:26    ERROR -  1119 INFO TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 3 in nav-bar should match expectations. - Got home-button, expected customizableui-special-spring1
02:33:26     INFO -  Stack trace:
02:33:26     INFO -  chrome://mochikit/content/browser-test.js:test_is:1290
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:placementArraysEqual:143
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:assertAreaPlacements:132
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/browser_allow_dragging_removable_false.js:null:17
02:33:26     INFO -  Not taking screenshot here: see the one that was previously logged
02:33:26    ERROR -  1120 INFO TEST-UNEXPECTED-FAIL | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 4 in nav-bar should match expectations. - Got customizableui-special-spring1, expected forward-button
02:33:26     INFO -  Stack trace:
02:33:26     INFO -  chrome://mochikit/content/browser-test.js:test_is:1290
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:placementArraysEqual:143
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/head.js:assertAreaPlacements:132
02:33:26     INFO -  chrome://mochitests/content/browser/browser/components/customizableui/test/browser_allow_dragging_removable_false.js:null:17
02:33:26     INFO -  1121 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 5 in nav-bar should match expectations. -
02:33:26     INFO -  1122 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 6 in nav-bar should match expectations. -
02:33:26     INFO -  1123 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 7 in nav-bar should match expectations. -
02:33:26     INFO -  1124 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 8 in nav-bar should match expectations. -
02:33:26     INFO -  1125 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 9 in nav-bar should match expectations. -
02:33:26     INFO -  1126 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Should no longer be in default state. -
02:33:26     INFO -  1127 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | forward-button was not able to move to palette -
02:33:26     INFO -  1128 INFO TEST-PASS | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Should be in default state again. -
02:33:26     INFO -  1129 INFO Leaving test bound
02:33:26     INFO -  GECKO(2712) | MEMORY STAT | vsize 808MB | vsizeMaxContiguous 616MB | residentFast 290MB | heapAllocated 130MB
02:33:26     INFO -  1130 INFO TEST-OK | browser/components/customizableui/test/browser_allow_dragging_removable_false.js | took 277ms
Summary: Intermittent TV (Verify) failure - browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 0 in nav-bar should match expectations. - Got forward-button, expected back-button → Intermittent failure - browser/components/customizableui/test/browser_allow_dragging_removable_false.js | Item 0 in nav-bar should match expectations. - Got forward-button, expected back-button
Thanks Eliza- TV failed and now we see 5%+ failure rate on this.  The identified root cause seems valid as the test was changed there (Bug 1438490)

:Gijs, I see that you authored bug 1438490, any chance you can take a look at this?  It seems to be osx/win:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1459913
Blocks: 1438490
Flags: needinfo?(jmaher) → needinfo?(gijskruitbosch+bugs)
Comment hidden (Intermittent Failures Robot)
Assignee

Updated

Last year
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: leave-open
Priority: -- → P5
Whiteboard: [retriggered][stockwell needswork:owner] → [retriggered]
Assignee

Comment 5

Last year
I have a patch but inbound is closed. :-\
Priority: P5 → --
Whiteboard: [retriggered] → [retriggered][stockwell needswork:owner]

Comment 6

Last year
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/184216421caa
fix removable_false test to always execute the correct drag (layout race), rs=test-only
Assignee

Comment 8

Last year
No new failures since this landed -> FIXED.
Status: ASSIGNED → RESOLVED
Closed: Last year
Keywords: leave-open
Resolution: --- → FIXED
Assignee

Updated

Last year
Target Milestone: --- → Firefox 62
Whiteboard: [retriggered][stockwell needswork:owner] → [retriggered][stockwell fixed:timing]
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.