Closed Bug 1459953 Opened 2 years ago Closed 3 months ago

Show all service worker states

Categories

(DevTools :: Application Panel, enhancement, P1)

61 Branch
enhancement

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: jdescottes, Assigned: ladybenko)

References

(Depends on 1 open bug, Blocks 3 open bugs)

Details

(Whiteboard: [m1.1-mvp])

Attachments

(2 files)

Temporary list of states:

Lifecycle Status
- installing
- installed (waiting)
- activating
- activated
- failed/redundant

Running Status
- starting (transition after clicking start)
- running
- stopping (transition after clicking stop)
- stopped

The application panel should display the exact state for each service worker.
Blocks: 1459955
Product: Firefox → DevTools
Priority: -- → P2
Depends on: 1595969
Depends on: 1595964
Depends on: 1459962
Whiteboard: [m1.1-mvp]
Priority: P2 → P3
Whiteboard: [m1.1-mvp] → [m1.1-reserve]
Priority: P3 → P2
Whiteboard: [m1.1-reserve] → [m1.1-mvp]

Bug 1596929 added this for Debugger.

See Also: → 1596929
Assignee: nobody → balbeza
Status: NEW → ASSIGNED
Priority: P2 → P1
Blocks: 1619221
Duplicate of this bug: 1215386
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71141fa6d324
Part 1: Show all service worker states r=jdescottes,fluent-reviewers,flod
https://hg.mozilla.org/integration/autoland/rev/1a8916dc09ee
Part 2: Add mochitest r=jdescottes
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1f26abec0a60
Part 1: Show all service worker states r=jdescottes,fluent-reviewers,ochameau,flod
https://hg.mozilla.org/integration/autoland/rev/69f90abbb577
Part 2: Add mochitest r=jdescottes
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Flags: needinfo?(balbeza)
You need to log in before you can comment on or make changes to this bug.