Closed Bug 1460186 Opened 4 years ago Closed 1 year ago

input type=file is sensitive to height (while chrome and safari don't)

Categories

(Core :: Layout: Form Controls, defect, P2)

61 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1457628
Webcompat Priority revisit

People

(Reporter: karlcow, Unassigned)

References

Details

(Whiteboard: [webcompat])

Attachments

(1 file)

If I understand Bug 52500 introduces the possibility to style <input type="file"/> with CSS.


There are different behaviors on macOS and Android at least in between Firefox and Chrome/Safari. (See the screenshot)

Test case:
data:text/html,<!doctype html><html style="background-color:pink;height:100vh"><input type="file" style="height:50px;background-color:gold;"/></html>


* Safari Chrome: leave the widget size as-is but grows the box.
* Firefox: changes the style of the widget and make it fill the box.


See https://webcompat.com/issues/16794



(needs testing on Edge)
Flags: webcompat?
See Also: → input[type=file]
This is effectively the same underlying cause of bug 1457628, see there for more context.
See Also: → 1457628
Priority: -- → P2

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

Note: the site this was reported against has fixed the issue on their end. Probably still good to eventually fix this though.

Webcompat Priority: ? → revisit
Flags: webcompat?

I think this is fixed. In Firefox Nightly, the testcase from comment 0 now renders the same as Chrome/Safari (i.e. we match the renderings shown in the screenshot).

Looks this was a dupe of bug 1457628 given comment 1 here. I confirmed that the fix range seems to match, using this command, straddling the date that bug 1457628 was fixed:

mozregression  --pref "security.sandbox.content.level:0"  --bad 2019-07-11 --good 2021-07-13 --find-fix

(and indeed, the "bad" build is "bad" and the "good" build is "good")

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1457628
You need to log in before you can comment on or make changes to this bug.