Closed Bug 1460241 Opened 3 years ago Closed 2 years ago

No reminder set when saving an invitation copy even if the default reminder is enabled for events

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

Lightning 5.4.7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
6.2.2.1

People

(Reporter: uzivatel919, Assigned: MakeMyDay)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36 OPR/52.0.2871.99

Steps to reproduce:

1. Make some regular event saved from mailed invitation.
2. Sent another invitation of the same event with change for just one day.
3. Save copy of one-day-change invitation. (Event copy.)
4. Now event copy reminder is faulty: no dialog for custom reminder, TB still shows work if choose some of predefined options. 


Actual results:

Event copy reminder is faulty: no dialog for custom reminder, TB still shows work if choose some of predefined options.


Expected results:

On custom reminder option related dialog window should be opened. TB should no be still processing something.
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 52 Branch → Lightning 5.4.7
Displaying a popup each time to define a custom is not wanted in the first place, but I'm confirming that |save a copy| behaves differently then |accept| with regards to adding the default reminder if that is enabled. That should be fixed. Regarding promting for setting a custom reminder, we could think about a preference which is off by default to allow this - I we do so, this should apply to both accepted invitations and saved copies.

As a potential alternative for your use case, accepting an inviation also without sending a reply to the organizer will become more easy and obvious in TB 60, which comes with the additional benefit, that you can update the event in your calendar when receiving an invitation update instead of creating a second copy and deleting the first copy manually.
Assignee: nobody → makemyday
Status: UNCONFIRMED → ASSIGNED
Component: General → E-mail based Scheduling (iTIP/iMIP)
Ever confirmed: true
Summary: Faulty reminder on event copy → No reminder set when saving an invitation copy even if the default reminder is enabled for events
This adds the default reminder also when adding a received PUBLISHed itip message. This applies also to saving invitation copies since these are faking a PUBLISHed event and inject that in the usual processing.
Attachment #8997599 - Flags: review?(philipp)
Attachment #8997599 - Flags: approval-calendar-esr?(philipp)
Attachment #8997599 - Flags: approval-calendar-beta?(philipp)
Reporter, regarding being able to add custom reminders on saving the copy, feel free to file an enhancement request if your not satisfied with this fix, since we first here bring the behaviour when saving an invitation copy to par with the standard behaviour when receiving invitations.
Attachment #8997599 - Flags: review?(philipp)
Attachment #8997599 - Flags: review+
Attachment #8997599 - Flags: approval-calendar-esr?(philipp)
Attachment #8997599 - Flags: approval-calendar-esr+
Attachment #8997599 - Flags: approval-calendar-beta?(philipp)
Attachment #8997599 - Flags: approval-calendar-beta+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/905579e3ff37
Add the default reminder when saving invitation copies or adding received PUBLISHed events. r=philipp
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 6.5
Attachment #8997599 - Flags: approval-calendar-beta+
Target Milestone: 6.2 → 6.2.1
Target Milestone: 6.2.1 → 6.2.2
You need to log in before you can comment on or make changes to this bug.