Support for async expression evaluation in JSTerm

RESOLVED DUPLICATE of bug 1410820

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 1410820
Last year
Last year

People

(Reporter: Honza, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

JSTerm input should support async expression evaluation

The `await` keyword is currently not supported and evaluating the following expression fails:

> await fetch("https://api.github.com/");

Browser Console: uncaught exception: SyntaxError: Unexpected token, expected ";" (1:6)


---

Example of the right behavior:

>> await fetch("https://api.github.com/");
<- Response {type: "cors", url: "https://api.github.com/", redirected: false, status: 200, ok: true, …}

---

Note that executing only fetch properly logs a promise as follows:
>> fetch("https://api.github.com/");
<- Promise { <state>: "pending" }

Honza
Priority: -- → P3
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1410820
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.