Closed Bug 1460516 Opened 3 years ago Closed 3 years ago

browser.browserSettings.proxyConfig is undefined

Categories

(Developer Documentation Graveyard :: Add-ons, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1455755

People

(Reporter: timedum, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

10.01 KB, application/x-xpinstall
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180507191226

Steps to reproduce:

I've created an extension "Reload PAC button" with "browserSettings" in "permissions".

The I use browser.browserSettings.proxyConfig in background script.

I've attached my extension to replicate the problem. Break-point on background.js:17


Actual results:

In browser console I found "browser.browserSettings.proxyConfig is undefined"


Expected results:

browser.browserSettings.proxyConfig should be defined as for documentation
Component: Untriaged → WebExtensions: Request Handling
Keywords: testcase
Product: Firefox → Toolkit
See bug 1455755, so this bug should probably be about up updating the docs.
Thanks for the quick response.

Replacing `browser.browserSettings.proxyConfig` with `browser.proxy.settings` and changing the permission to `proxy` solved the issue.
(In reply to Shane Caraveo (:mixedpuppy) from bug 1455755, comment 27)
> For dev-doc: move docs for browserSettings.proxyConfig to proxy.settings. 
> browserSettings.proxyConfig should probably be documented as moved somehow,
> and that it is non-functional in fx59.
Status: UNCONFIRMED → NEW
Component: WebExtensions: Request Handling → Add-ons
Ever confirmed: true
Flags: needinfo?(wbamberg)
OS: Unspecified → All
Product: Toolkit → Developer Documentation
Hardware: Unspecified → All
Version: 61 Branch → unspecified
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1455755
I don't think a documentation bug should be a dupe of an add-on bug. Regardless, the article in question hasn't been updated.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
1455755 has dev-doc-needed which is handled when the bug is closed.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1455755
Flags: needinfo?(wbamberg)
You need to log in before you can comment on or make changes to this bug.