Closed Bug 14607 Opened 21 years ago Closed 21 years ago

(win32) Maximizing apprunner triggers assert in table code

Categories

(Core :: Layout: Tables, defect, P3, critical)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 13881

People

(Reporter: kmcclusk, Assigned: karnaze)

Details

Load appruner
Click on the maximize button.
The appprunner asserts.



nsDebug::Assertion(const char * 0x015184a0, const char * 0x01518494, const char
* 0x01518454, int 90) line 181 + 13 bytes
FixedTableLayoutStrategy::AssignPreliminaryColumnWidths(int 3000) line 90 + 32
bytes
BasicTableLayoutStrategy::Initialize(nsSize * 0x00000000, int 1, int 3000) line
79
nsTableFrame::BalanceColumnWidths(nsIPresContext & {...}, const
nsHTMLReflowState & {...}, const nsSize & {...}, nsSize * 0x00000000) line 3842
nsTableFrame::Reflow(nsTableFrame * const 0x02de2424, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 2260
nsTreeFrame::Reflow(nsTreeFrame * const 0x02de2424, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 325 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x02de2420, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x02de2544, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 906 + 37 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x02de2540, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x00d8ff24, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsContainerFrame::ReflowChild(nsIFrame * 0x00d8ff20, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x02de0594, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 330
nsContainerFrame::ReflowChild(nsIFrame * 0x02de0590, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x02dda374, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 516
PresShell::ResizeReflow(PresShell * const 0x0293c060, int 3000, int 1875) line
949
PresShell::ResizeReflow(PresShell * const 0x0293c064, nsIView * 0x0293c480, int
3000, int 1875) line 2132
nsViewManager::SetWindowDimensions(nsViewManager * const 0x0293c980, int 3000,
int 1875) line 366
nsViewManager::DispatchEvent(nsViewManager * const 0x0293c980, nsGUIEvent *
0x0012d408, nsEventStatus & nsEventStatus_eIgnore) line 1527
HandleEvent(nsGUIEvent * 0x0012d408) line 63
nsWindow::DispatchEvent(nsWindow * const 0x0293c344, nsGUIEvent * 0x0012d408,
nsEventStatus & nsEventStatus_eIgnore) line 338 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012d408) line 359
nsWindow::OnResize(nsRect & {...}) line 3138 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1234584, long *
0x0012d60c) line 2586 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x06280590, unsigned int 71, unsigned int 0, long
1234584) line 454 + 27 bytes
USER32! 77e71ab7()
USER32! 77e72fbe()
NTDLL! 77f7624f()
DocumentViewerImpl::SetBounds(DocumentViewerImpl * const 0x02910100, const
nsRect & {...}) line 476
nsWebShell::SetBounds(nsWebShell * const 0x028cd340, int 0, int 0, int 200, int
125) line 1201
nsHTMLFrameInnerFrame::Reflow(nsHTMLFrameInnerFrame * const 0x028cd5e4,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 976
nsContainerFrame::ReflowChild(nsIFrame * 0x028cd5e0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
nsHTMLFrameOuterFrame::Reflow(nsHTMLFrameOuterFrame * const 0x028cd9d4,
nsIPresContext & {...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState &
{...}, unsigned int & 0) line 394
nsBoxFrame::FlowChildAt(nsIFrame * 0x028cd9d0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 1, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e33e4c, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsContainerFrame::ReflowChild(nsIFrame * 0x01e33e48, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
nsScrollFrame::Reflow(nsScrollFrame * const 0x027738d4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 670
nsBoxFrame::FlowChildAt(nsIFrame * 0x027738d0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e307fc, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsBoxFrame::FlowChildAt(nsIFrame * 0x01e307f8, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 0, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e2ecd4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsBoxFrame::FlowChildAt(nsIFrame * 0x01e2ecd0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
nsCalculatedBoxInfo & {...}, int & 1, nsString & {...}) line 1051
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}) line 682
nsBoxFrame::Reflow(nsBoxFrame * const 0x01e14ef4, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 517
nsContainerFrame::ReflowChild(nsIFrame * 0x01e14ef0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x02763734, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 330
nsContainerFrame::ReflowChild(nsIFrame * 0x02763730, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 372 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x0275ab44, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 516
PresShell::ResizeReflow(PresShell * const 0x01b98860, int 15300, int 10755) line
949
PresShell::ResizeReflow(PresShell * const 0x01b98864, nsIView * 0x01b72cf0, int
15300, int 10755) line 2132
nsViewManager::SetWindowDimensions(nsViewManager * const 0x01b974f0, int 15300,
int 10755) line 366
nsViewManager::DispatchEvent(nsViewManager * const 0x01b974f0, nsGUIEvent *
0x0012f558, nsEventStatus & nsEventStatus_eIgnore) line 1527
HandleEvent(nsGUIEvent * 0x0012f558) line 63
nsWindow::DispatchEvent(nsWindow * const 0x01b98ee4, nsGUIEvent * 0x0012f558,
nsEventStatus & nsEventStatus_eIgnore) line 338 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f558) line 359
nsWindow::OnResize(nsRect & {...}) line 3138 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1243112, long *
0x0012f75c) line 2586 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x01d6065a, unsigned int 71, unsigned int 0, long
1243112) line 454 + 27 bytes
USER32! 77e71ab7()
USER32! 77e72fbe()
NTDLL! 77f7624f()
DocumentViewerImpl::SetBounds(DocumentViewerImpl * const 0x01b6c6e0, const
nsRect & {...}) line 476
nsWebShell::SetBounds(nsWebShell * const 0x016dfe10, int 0, int 0, int 1020, int
717) line 1201
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012f97c) line 506
nsWindow::DispatchEvent(nsWindow * const 0x016de274, nsGUIEvent * 0x0012f97c,
nsEventStatus & nsEventStatus_eIgnore) line 338 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f97c) line 359
nsWindow::OnResize(nsRect & {...}) line 3138 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1244172, long *
0x0012fb80) line 2586 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x516c0580, unsigned int 71, unsigned int 0, long
1244172) line 454 + 27 bytes
USER32! 77e71ab7()
USER32! 77e72fbe()
NTDLL! 77f7624f()
USER32! 77e7288d()
USER32! 77e72918()
nsWindow::WindowProc(HWND__ * 0x516c0580, unsigned int 274, unsigned int 61488,
long 7340748) line 461 + 31 bytes
USER32! 77e71ab7()
USER32! 77e71a77()
NTDLL! 77f7624f()
USER32! 77e7288d()
USER32! 77e72918()
nsWindow::WindowProc(HWND__ * 0x516c0580, unsigned int 161, unsigned int 9, long
7340748) line 461 + 31 bytes
USER32! 77e71250()
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
The stack looks like the one in bug 13881.

*** This bug has been marked as a duplicate of 13881 ***
Status: RESOLVED → VERIFIED
Verified dup of #13881
You need to log in before you can comment on or make changes to this bug.