Closed Bug 1460848 Opened 4 years ago Closed 3 years ago

if a node is selected, clicking the "reveal" link again will not redirect the user to the already selected node

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox62 wontfix, firefox63 verified)

VERIFIED FIXED
Firefox 63
Tracking Status
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: danibodea, Assigned: jdescottes)

References

Details

Attachments

(1 file)

STR:
1. Reach this page: https://www.polymer-project.org/2.0/start/quick-tour
2. Open Developer Tools / Inspector tab.
3. Right-click on the body and click "Expand all".
4. Scroll the HTML code to <slot id="slot"></slot>
5. Click on the "reveal" link displayed while hovering over the <label> tag.
6. Notice that the inspector tab is auto-scrolled so the corresponding node and the node is selected/highlighted.
7. Scroll back up to the <slot id="slot"></slot>
8. Click on the reveal link displayed while hovering over the <label> tag.
9. Notice that the code is NOT auto-scrolled to the (already) selected node.
Expected: The inspector should be auto-scrolled to the (already selected) node.
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1459829
Sorry but I don't think this is a duplicate. This bug means that clicking reveal on the slotted version of an "already selected" node doesn't scroll the markup view. But the node is still correctly selected. The other bug is a selection issue, not a scrolling issue.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Product: Firefox → DevTools
Assignee: nobody → jdescottes
Status: REOPENED → ASSIGNED
Comment on attachment 8987539 [details]
Bug 1460848 - Always scroll to container element when clicking on reveal;

https://reviewboard.mozilla.org/r/252778/#review259290

Makes sense
Attachment #8987539 - Flags: review?(bgrinstead) → review+
Priority: P3 → P2
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ed0176b3adac
Always scroll to container element when clicking on reveal;r=bgrins
Sorry about that, fixed the eslint failure in the latest patch.
Flags: needinfo?(jdescottes)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/79aabc0f2db2
Always scroll to container element when clicking on reveal;r=bgrins
https://hg.mozilla.org/mozilla-central/rev/79aabc0f2db2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
This issue is verified in Nightly v63.0a1 on Windows 10, Ubuntu 16.04 and Mac OS X 10.12.6.
Status: RESOLVED → VERIFIED
Hi Julian, is there a benefit in having this patch uplifted to 62 beta or can I change the tracking flag for Firefox 62 from affected to wontfix?

Thanks
Flags: needinfo?(jdescottes)
Thanks Pascal, no need to uplift this, webcomponents will only be enabled starting with 63. I updated the tracking flag for Firefox 62 accordingly.
Flags: needinfo?(jdescottes)
Flags: qe-verify+
Flags: needinfo?(timea.zsoldos)
I have reproduced this issue using Firefox 62.0a1 (2018.05.01) on Windows 10 x64.
I can confirm this issue is fixed, I verified using Firefox 63.0b3 on Ubuntu 16.04 x64, Windows  10 x64 and Mac OS X 10.13.
Flags: qe-verify+
Flags: needinfo?(timea.zsoldos)
You need to log in before you can comment on or make changes to this bug.