release_eta should not default to 'null', but an empty string.

RESOLVED FIXED

Status

defect
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: sfraser, Assigned: sfraser)

Tracking

({regression})

unspecified

Firefox Tracking Flags

(firefox61 fixed, firefox62 fixed)

Details

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #1458854 +++

Updating release_eta for this one condition has caused it to treat the 'null' value specially in the parameters. It should default to ''
(Assignee)

Updated

a year ago
Assignee: nobody → sfraser
(Assignee)

Updated

a year ago
Attachment #8975073 - Flags: review?(aki)

Comment 2

a year ago
mozreview-review
Comment on attachment 8975073 [details]
Bug 1460906 Fix use of config.params and release_eta

https://reviewboard.mozilla.org/r/243416/#review249290

I think this works. Ideally we fix https://hg.mozilla.org/build/tools/file/tip/buildfarm/release/release-runner3.py#l211 to .get('release_eta', '') as well.
Attachment #8975073 - Flags: review?(aki) → review+

Updated

a year ago
Whiteboard: [checkin-needed-beta]

Comment 3

a year ago
Pushed by sfraser@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc4f2d0a1dfb
Fix use of config.params and release_eta r=aki
https://hg.mozilla.org/mozilla-central/rev/fc4f2d0a1dfb
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Attachment #8975853 - Flags: review?(rail) → review+
You need to log in before you can comment on or make changes to this bug.