Closed Bug 146104 Opened 23 years ago Closed 19 years ago

Move localconfig enumerations into database.

Categories

(Bugzilla :: Administration, task, P2)

2.15

Tracking

()

RESOLVED FIXED
Bugzilla 2.20

People

(Reporter: CodeMachine, Assigned: CodeMachine)

References

Details

Attachments

(1 file, 2 obsolete files)

We need to move the localconfig enumerations out of localconfig and into the
database.  This will allow:

- Editing through the web interface using my new administration architecture.
- Other things to be attached to them, such as sortkeys and isactive flags.
This refers to operating systems, platforms, priorities and severities.
Blocks: 97706
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18
Depends on: 67375
Also this will allow us to maintain referential integrity, ie if you try to
delete a platform value that is in use I don't think checksetup.pl currently
does anything to stop you.
Assignee: justdave → matty
QA Contact: matty → jake
Blocks: 153811
Matty, what are your plans? If you're going to do this for 2.18, let's just make
bug 144177 a dupe of this.
I've got a patch to do this for the op_sys field. The patch also allows logical
groupings of OS's for the search page (basically a glorified multiple select).
There's a UI that lets you add + delete os's and os groups, and you can also
assign sortkey values to them. i sent the patch out to the bugzilla developers
list for review, but i haven't gotten any responses yet. 

Is this the appropriate place for this code? Or should i open up a new bug and
attach it there?
This sounds like a good place.  I've been intending to look at that but haven't
had a chance yet.  Would it be possible to upload it here as a straight diff
file (without the tar/gzip)?  You can "cvs diff -u > patchfile" to diff the
existing files and "diff -u /dev/null newfile >> patchfile" to append the new
files onto the end of it before uploading.
Attached patch os group patch (obsolete) — Splinter Review
as requested, here's the patch in plaintext
Attachment #112539 - Flags: review?
op_sys_groups is a separate enhancement, which should probably be split out into
another patch.

You should also have a unique index on the name coluumn for op_sys.

checksetup needs to have $table definitions for new installs

+         "op_sys,(?!changed)" => sub {
+            use Data::Dumper;
+            $f = $ff = "op_sys.name";

you do't want Data::Dumper..

+++ editopsys.cgi	2003-01-23 19:00:11.000000000 -0800
@@ -0,0 +1,493 @@
+#!/usr/bonsaitools/bin/perl -w

Should run in taint mode, and probably be templatised, too
i've made all the changes bbaetz@acm.org requested in his review. i'll upload
the osgroup patch later today.
Attachment #112537 - Attachment is obsolete: true
Attachment #112539 - Attachment is obsolete: true
i should also note that doing the same thing for the rep_platform field  is
basically a cut and paste job from this patch (although i'm not bored enough at
my job today to actually do it).
Attachment #113119 - Flags: review+
Attachment #113119 - Flags: review+ → review?(bbaetz)
Hmm. I got an email saying:

"Dave Miller <justdave@netscape.com> has granted Jonathan Schatz
<jon@vmware.com>'s request for review:"

but that doesn't look like what's happened. But anyway, shouldn't we be fixing
this using custom fields? All I can see we'd get from this patch is more
migration problems...

Gerv
Hmm,I got that email too.

But yes, custfields are the way to go.
i'm confused. how exactly will a working version of custom fields solve the enum
problem? 
Because making os a custom field would move the possible values for it into the
database, and allow editing through the web interface/use of sortkeys, as this
bug requests.

Gerv
Attachment #112539 - Flags: review?
Taking Jake's bugs...  his Army Reserve unit has been deployed.
QA Contact: jake → justdave
Severity: normal → enhancement
I think it's probably best to get bug #69267 in first (which I'm actively
working on), and then this should be really simple with the new architecture.

I don't see custom fields fixing this up in the new future, but the new admin
architecture should.
Comment on attachment 113119 [details] [diff] [review]
redone op_sys patch

This is quite bitrotted...   waaaah! I want this :)

Amazing only 10 hunks of this incredibly huge patch fail to apply.
Attachment #113119 - Flags: review?(bbaetz) → review-
we're too close to 2.18 to take schema changes without good cause anyway. 
Pushing to 2.20
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
*** Bug 244968 has been marked as a duplicate of this bug. ***
*** Bug 247262 has been marked as a duplicate of this bug. ***
Bugzilla 2.20 feature set is now frozen as of 15 Sept 2004.  Anything flagged
enhancement that hasn't already landed is being pushed out.  If this bug is
otherwise ready to land, we'll handle it on a case-by-case basis, please set the
blocking2.20 flag to '?' if you think it qualifies.
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22
Enumerators have been removed in bug 17453. The UI to manage fields mentionned
in comment 1 has been added in bug 281876.
Blocks: 67375, 281876
Status: NEW → RESOLVED
Closed: 19 years ago
Depends on: bz-enums
No longer depends on: 67375
Resolution: --- → FIXED
Target Milestone: Bugzilla 2.22 → Bugzilla 2.20
QA Contact: justdave → default-qa
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: