Closed Bug 1461078 Opened 4 years ago Closed 4 years ago

Crash in nsInProcessTabChildGlobal::WrapObject

Categories

(Core :: DOM: Core & HTML, defect)

61 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1453951
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- fixed
firefox62 --- fixed

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-a9384790-98bb-4bbe-9a57-9fa2c0180512.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll nsInProcessTabChildGlobal::WrapObject dom/base/nsInProcessTabChildGlobal.h:52
1 xul.dll mozilla::dom::NativeInterface2JSObjectAndThrowIfFailed dom/bindings/BindingUtils.cpp:1063
2 xul.dll static class JSObject* mozilla::dom::WrapNativeISupports<nsISupports> dom/bindings/BindingUtils.h:1664
3 xul.dll mozilla::dom::WrapNativeHelper<nsISupports, 0>::Wrap dom/bindings/BindingUtils.h:1741
4 xul.dll static class JSObject* mozilla::dom::FindAssociatedGlobal<nsISupports> dom/bindings/BindingUtils.h:1757
5 xul.dll static class JSObject* mozilla::dom::FindAssociatedGlobal<nsISupports*> dom/bindings/BindingUtils.h:1788
6 xul.dll mozilla::dom::ChildSHistoryBinding::Wrap dom/bindings/ChildSHistoryBinding.cpp:427
7 xul.dll mozilla::dom::ChildSHistoryBinding::Wrap<mozilla::dom::ChildSHistory> dist/include/mozilla/dom/ChildSHistoryBinding.h:44
8 xul.dll mozilla::dom::ChildSHistory::WrapObject docshell/shistory/ChildSHistory.cpp:127
9 xul.dll XPCConvert::NativeInterface2JSObject js/xpconnect/src/XPCConvert.cpp:788

=============================================================

crashes with this signature are newly showing up in firefox 61 with MOZ_CRASH(We should never get here!) :-)
Flags: needinfo?(peterv)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1453951
Flags: needinfo?(peterv)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.