[BLOCKER] Can't select non-text nodes such as HR, IMG, and table elements

VERIFIED FIXED in M10

Status

()

Core
Editor
P1
blocker
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Charles Manske, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: will verify in 10/14 build)

(Reporter)

Description

19 years ago
We used to be able to click on a HR or Image to select it. That doesn't work
any more. If you can't select an image, you can't bring up the property dialog
for that image, thus it blocks work on editing properties of an image.
Tables are a problem. While I understand that people complained about not
being able to select text in tables, we need to be able to select table cells
in both the browser and editor.

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M12

Comment 1

19 years ago
the portion about hr and image is critical for beta.  If it's an easy, safe fix,
please try to get it in for M11.  Otherwise, M12.
(Reporter)

Updated

19 years ago
Blocks: 14783
(Reporter)

Comment 2

19 years ago
*** Bug 14821 has been marked as a duplicate of this bug. ***

Updated

19 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 3

19 years ago
I thought I put comments in here earlier today but apparently not.  The
workaround for this bug should be to place the caret immediately before or after
the image/hrule you want to select and then use the shift and arrow to select it.
(Though this is far from obvious.)

Unfortunately the selection seems to disappear.  Also, no dialog comes up at all
for hrule (an empty image dlog comes up for an image).  Has anyone reported this
problem?

This happens on Mac as well so changing platform/OS to ALL.
(Reporter)

Comment 4

19 years ago
I don't think your "workaround" sets the same selection as clicking on the
object used to. Thus when you try to run a property dialog, GetSelectedElement()
fails because it is very fussy about having just the object in question
selected. HRules will be inserted instead of property editing in this case,
other dialogs will not show the settings of the intended object.
MIKE: ARE YOU FIXING THIS SOON PLEASE?

Updated

19 years ago
Priority: P2 → P1
Target Milestone: M12 → M10

Comment 5

19 years ago
Mike, please look at this today.  If it can be fixed safely, it should go in for
M10, which pretty much means today sometime.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
this is fixed. i thought i updated the bug sorry

Updated

18 years ago
Whiteboard: will verify in 10/14 build

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
okay you can select it all right but now we have another
problem in that you can't un-select it so you can type
text next to the object...I filed another bug...
You need to log in before you can comment on or make changes to this bug.