Status

RESOLVED DUPLICATE of bug 121084
17 years ago
14 years ago

People

(Reporter: siffert, Assigned: Matti)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm afraid this is going to be a strange bug report.  I wrote a perl script to
open, read, and print out a jpg image to STDOUT.  Every time I run it in mozilla
RC2, what happens is that the jpg happily prints out from top to bottom, and
then when it gets to the bottom, it disappears to be replaced with the
non-selectable mesasge "The image "[full href to image here]" cannot be
displayed, because it contains errors."

Netscape and IE display it fine.  In Mozilla if I put some gobbledygook into the
location bar href and hit enter (404) and then hit "Back", the image shows up
fine.  The message appears to be generated from mozilla; it is not selectable
text.  View source prompts me to download the image, which is then displayable
in any image application.  The image as generated on disk (what the script reads
from) is valid.

Any clues?  I can give you more details but it would involve showing you my perl
script, which seems like a tangent.  I'm hoping that this is just a known
mozilla bug that I haven't noticed elsewhere in bugzilla.

Thanks
Curt
(Assignee)

Comment 1

17 years ago
Does it work (for the first time) if you delete the cache and load the image ?
(see the duped bug 145993)
(Reporter)

Comment 2

17 years ago
Maybe this should be smooshed into 121084 .  

That's exactly the bug - deleting cache didn't do it, but setting it to "when
page is out of date" rather than "every time I load the page" makes it work again.

Please note - shift-reload doesn't work in this case because the image was
generated by hitting a submit button!  So there was no other workaround.  I hope
this one is fixed by 1.0 - I just spent two hours trying to research why my perl
code was buggy.  :(  (Oh well, it was billable.)

Thanks for the dupe pointer.
(Assignee)

Comment 3

17 years ago
Thanks !

BTW: i don't think that this will be fixed for 1.0...


*** This bug has been marked as a duplicate of 121084 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.