align=justify causes rtl text to be jumbled

RESOLVED FIXED in mozilla1.2alpha

Status

()

Core
Layout: Text
--
major
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Shoshannah Forbes, Assigned: Frank Tang)

Tracking

({rtl})

Trunk
mozilla1.2alpha
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0+)
Gecko/20020520
BuildID:    2002052008

when a block is set to align=justify, hebrew text becomes jumbled and unreadble.
this is espcially common with files comming from word (like the urls above)

Reproducible: Always
Steps to Reproduce:
1.have two text paragrphs: one align right, the other justify
2.compare


Actual Results:  justififed Hebrew text is jumbled and unreadble

Expected Results:  should be fine
(Reporter)

Comment 1

16 years ago
Created attachment 84609 [details]
Test Case
(Reporter)

Comment 2

16 years ago
Created attachment 84610 [details]
screen shot of the test case

Comment 3

16 years ago
WFM Win95 RC2 (2002 05 20 08)
Mea culpa: I should have given ftang a testcase with justified text to check on Mac.
Assignee: mkaply → ftang
http://lxr.mozilla.org/mozilla/source/gfx/src/mac/nsUnicodeRenderingToolkit.cpp#1416

  // fix me ftang -  handle (mRightToLeftText) here
(Assignee)

Comment 6

16 years ago
accept. I am not sure when will I work on this. 
I knew this problem and don't think need to fix that right away. I could be
wrong. how many top sites in Hebrew/Arabic use align=justify ?
Or any other reason I should fix this asap ?
Otherwise, I will keep this is one item "to-be-hack" :)
Status: NEW → ASSIGNED
(Reporter)

Comment 7

16 years ago
>how many top sites in Hebrew/Arabic use align=justify ?

Speaking of this- do we have an "offical" list of ME top sites?

In general, I am seeing this problem more and more lately- this is esp. bad 
whith pages genarated from word
(Reporter)

Comment 8

16 years ago
just went back to mozilla.org.il (mozilla Hebrew l10n page), and found that the
evanglism letter there ( http://www.mozilla.org.il/evangel.shtml ) uses that
attribute, thus making it almost unreadble with my mozilla (build ID 2002061603
on Mac OSX)
(Reporter)

Comment 9

16 years ago
Yet another site with the same problem:
http://www.blabla4u.com/sites/blabla4u/ShowMessage.asp?ID=992320
It seems like align=justify is the latest fashion- which makes reading the web
really hard.
any idea when this will be fixed?
(Reporter)

Comment 10

16 years ago
and another example:
http://www.sportenter.co.il/main.asp
this is getting more and more annoying...
(Assignee)

Comment 11

15 years ago
set to m1.2alpha
Target Milestone: --- → mozilla1.2alpha

Comment 12

15 years ago
Created attachment 98303 [details]
Arabic Windows XP Screenshot

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020905

I'm seeing this on Arabic pages using Windows XP as well. It seems that not all
fonts or font sizes are effected by this bug. I'm uploading a testcase and a
screenshot showing some distorted text using "Arabic Transparent." Mozilla's
default Arabic font on windows.

Comment 13

15 years ago
Created attachment 98304 [details]
Arabic testcase used in screenshot
*** Bug 177274 has been marked as a duplicate of this bug. ***
Summary: align=justify cases rtl text to be jumbled → align=justify causes rtl text to be jumbled
(Reporter)

Comment 15

15 years ago
looks fixed here for some time now
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 16

15 years ago
ok, 
http://www.unisys.com  right column is also test case, inspite it is english.
we at BeOS had same problem and reason is word-by-word aligned rendering in
GFX::DrawString(*, aSpacing !=0,*)

Comment 17

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.