Closed Bug 14615 Opened 21 years ago Closed 20 years ago

Changing # of news msgs to download doens't take effect

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: skasinathan, Assigned: Bienvenu)

Details

Overview Description:
Unable to see/download 1000 Newsgroups headers. Seth saw this in one of the Lab
machines I was working on.

Steps to Reproduce:
1. Start Messenger. Click on a Newsgroup (news.mozilla.org)
2. Choose File | Subscribe and type netscape.public.mozilla.mail-news.
3. Choose Edit | Account Setup. Select the newsgroup(news.mozilla.org), click on
server. Change the value in Number of headers to download to 1000. Click ok.
4. Now in 3 pane window click on the newsgroup. You will see it downloads only
50 headers.

Build Date & Platform Bug Found:
9/21/99 and 9/22/99 Windows release build.
QA Contact: lchiang → huang
Summary: Unable to download 1000 Newsgroups headers. → Changing the number of messages to download does not take effect
I'm going to change the summary from "Unable to download 1000 Newsgroups
headers" to "Changing the number of messages to download does not take effect."
accepting.  marking all milestone 11.
Summary: Changing the number of messages to download does not take effect → Changing # of news msgs to download doens't take effect
Target Milestone: M11 → M13
M13
Assignee: sspitzer → bienvenu
Status: ASSIGNED → NEW
I'll look at this (I wonder if it's still valid)
I believe that this bug is duplicate of bug#16568
No, it's similar, but I think they're different. The dialog described in 16568
lets you override the default number of headers to download set by the pref ui,
if there are more than that default number of headers to download.
I'm not seeing the chunk download feature engaging in a new account at all. No
matter what the number of messages is.  I'm seeing migration problems, which
I'll write up, but I seeing this engage only on migrated profiles (and you can't
turn it off).  So I think there's a few bugs related to this problem.
Oh, one more thing... when changing the number in the ui, it does stick in the
ui and it does change the value of mail.server.serverN.max_articles to the new
value, it just doesn't engage.
that last thing is exactly the bug I'm trying to fix - nothing to do with
migration or anything like that.
Target Milestone: M13 → M15
moving to m16
Target Milestone: M15 → M16
Cleanup work, marking M18.
Target Milestone: M16 → M18
luis - can you give this a try in the latest Windows build and report what you 
see?
adding nsbeta3 keyword
Keywords: nsbeta3
adding correctness keyword to go w/nsbeta3 nomination
Keywords: correctness
this seems to be fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Yes. verified on 07-24-09-M17 WinNT commercial build
Changing # of news msgs to download did take effect now. Marking as verified!!
Status: RESOLVED → VERIFIED
I'm reopening this bug.  

If I type 105 (or some number xx) in the Download header dialog, then I should 
see 'Total: xx' (not the Unread)in the status bar. Right?  Correct me if I'm 
wrong here. 

Tested by creating a new News Account and subscribed to some newsgroup.  
Build: 2000-07-31-05-M17 windows commercial build.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Not sure what status message you're talking about - I see a status that says
"Received 105 of 105 headers" when I put 105 in the dialog. I don't see any
total message.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Bienvenu, Further right in the status bar there is a display for Unread messages
and Total msgs (which reads "Unread: n Total: xx").  So this "Total: xx" should
be equal to the number of headers downloaded, right?
no, it's the total number of messages in the newsgroup on the server, not
downloaded to the client.
well, that turns out not to be true. I don't know how it works in the new world
order. But we used to try to make sure that the total was at least >= the number
of unread messages, and the number of unread messages is supposed to be the
number of unread messages in the group, irregardless of whether you've
downloaded them. But whatever, this bug is about how many headers are
downloaded, and for that, you should look at the progress status messages.
Bienvenu, Thanks for Clarifying. I had the same question whether 'Total' is 
number of msgs downloaded or total number msgs in the server. 

Here is what I see now. Created a new profile, new News account and subscribed 
to two newsgroups. (n.p.m.builds and n.p.m.mailnews).

1. clicked on the builds newsgroup and typed 105 headers to download. I see 
"Received 105 of 105 headers" in the status bar. But further right I see 
"Unread: 103 Total: 103". 

2. clicked on the mail-news newsgroup and typed 15 headers to download. I see 
"Received 15 of 15 headers" in the status bar. But further right I see "Unread: 
14 Total: 14".  When I counted manually the number of messages in the thread 
pane is only 14. 
oh, that's probably because 1 or 2 articles were cancelled in the range of
articles we downloaded. We can't know that in advance - we just ask the server
for a range of articles - if it gives us less because some are missing, we don't
turn around and ask for more. We've always worked that way.
Thanks Bienvenu!!

Restoring Verified status.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.