Closed Bug 1461611 Opened 3 years ago Closed 1 year ago

Youtube videos only appear with a page title of "YouTube" in Firefox on Android

Categories

(Web Compatibility :: Mobile, defect, P1)

All
Android
defect

Tracking

(Webcompat Priority:?, fennec?, firefox60 affected, firefox61 affected, firefox62 affected, firefox63 affected, firefox64 affected, firefox65 affected)

RESOLVED FIXED
Webcompat Priority ?
Tracking Status
fennec ? ---
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected
firefox63 --- affected
firefox64 --- affected
firefox65 --- affected

People

(Reporter: levente.sacal, Unassigned)

References

Details

(Whiteboard: [webcompat][notcontactready])

Attachments

(1 file)

Device(s):
 -  Sony Xperia Z5 (Android 7.0);


Build(s):
 - Nightly 62.0a1 (2018-05-14);
 - Beta 61.0b5


Steps to reproduce:
 1. Start a Youtube video
 2. Watch the Android media control notification
 

Expected result:
- Youtube video title appears in the Android media control notification

Actual result:
- Youtube video url appears only in the notifications and not the title of the video

Notes:
- the video title appears on Release candidate 60.0 and Release 59.0.2
- On Chrome, the video title appears in the notification
Summary: Youtube page title does not in the Android media control notification → Youtube page title does not appear in the Android media control notification
tracking-fennec: --- → ?
Hardware: ARM → All
Component: General → Audio/Video
The problem is that Youtube is now using a page title of "Youtube" and I'm seeing this with older Firefox versions as well, so you probably caught this just as it was rolling out.

So I can't say whether this is a genuine bug of ours that Youtube is now hitting, or plainly Youtube's fault, but in any case it doesn't look like a recent regression on our side.
Component: Audio/Video → Mobile
Product: Firefox for Android → Tech Evangelism
Summary: Youtube page title does not appear in the Android media control notification → Youtube videos only appear with a page title of "YouTube" in Firefox on Android
Version: Firefox 62 → unspecified
Confirmed that Chrome Mobile gets a nice rich notification thingy... maybe they're using https://wicg.github.io/mediasession/?

Karl, can you take a look please?
Flags: needinfo?(kdubost)
Priority: -- → P1
See Also: → MediaSession
(In reply to Mike Taylor [:miketaylr] from comment #2)
> Confirmed that Chrome Mobile gets a nice rich notification thingy... maybe
> they're using https://wicg.github.io/mediasession/?

Yes, YouTube is using the Media Session API.
Thanks Mounir. So this is not really a Tech Evangelism bug, we just need to implement this API.
Flags: needinfo?(kdubost)
(I guess we'll just leave it here since it's blocking the parent bug)
Whiteboard: [webcompat][notcontactready]
Depends on: MediaSession
See Also: MediaSession
Product: Tech Evangelism → Web Compatibility

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

This seems to be fixed now (in Fennec, at least).

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.