Closed Bug 1461880 Opened 2 years ago Closed 2 years ago

Web Extension localization failed in Nightly62.0a1

Categories

(WebExtensions :: General, defect)

62 Branch
x86_64
Windows 10
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1461881

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: intl, regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Web Extension localization failed on Nightly Build ID 20180515220059

Reproducible : always

Steps To Reproduce:
1. Start Localized Nightly build, in my case ja build.
2. Install any localized Web Extensions (such as Tree Style Tab https://addons.mozilla.org/en-US/firefox/addon/tree-style-tab/ )
3. Update Nightly 20180515220059 from 20180515100038

Actual Results:
Web Extension localization failed. Label and Option of the extension are in English.

Expected results:
Web Extension localization should be working properly.


Regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cf3ee14023483cbbb57129479537c713e22c1980&tochange=380cf87c1ee3966dd94499942b73085754dc4824
See Also: → 1461881
Attached image shot.png
This works as expected for me
Seems regressed by Bug 1459721

Nathan Froyd,
It seems that your bunch of patches caused the regression. Can you look in to this?
Blocks: 1459721
Flags: needinfo?(nfroyd)
(In reply to Kris Maglione [:kmag] (long backlog; ping on IRC if you're blocked) from comment #1)
> Created attachment 8976027 [details]
> shot.png
> 
> This works as expected for me

Probably, Your Nightly build is not a recent Nightly, or not for Windows10 x64 or not with clean profile + the WebExt.
I am having a really hard time imagining scenarios in which removing these bits from the build cause localization to fail.  Did you bisect this to those patches?
Flags: needinfo?(nfroyd)
(In reply to Nathan Froyd [:froydnj] from comment #4)
> I am having a really hard time imagining scenarios in which removing these
> bits from the build cause localization to fail.  Did you bisect this to
> those patches?

I just assumed the patches causes the problem. may be due to others.

There are no localized build between these build.
And Mozregression seems do not support localized build(https://bugzilla.mozilla.org/show_bug.cgi?id=1401649 )
regression range via local ja build:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=cf3bdac11bc8&tochange=9260cc524bb5
Blocks: 1454912
No longer blocks: 1459721
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1461881
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.