external stylesheet not being applied to XHTML page

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: nswan, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

The page at http://www.usd.edu/csci/site_new/index.shtml is a XHTML 1.0
Transitional document.  It references, using the <link> tag, a stylesheet at
http://www.usd.edu/csci/site_new/style.css.  The external stylesheet is not
applied, however.  This has been reproduced with another webpage which is
written in XHTML 1.0 Strict.  The styles appear if included inline in the code
(using <style> tag).  The XHTML page and style sheet have been validated at
http://www.w3.org.  I could not, in my exhaustive searches, locate a reported
bug similar to this.  Please advise.

Reproducible: Always
Steps to Reproduce:
1. Create XHTML 1.0 document (Transitional or Strict)
2. Link to an external style sheet


Actual Results:  Style sheet was not applied. Text appeared with default settings.

Expected Results:  Style sheet should have been applied.  Text should have
appeared with different font, size, color, etc.
Your server is serving up the CSS stylesheet with the MIME-type "application/x-pointplus", when it should be "text/css". In strict mode (including XHTML), Mozilla only applies text/css stylesheets. Contact your server administrator.  INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.