Closed Bug 1462556 Opened 5 years ago Closed 4 years ago

Mark HTTP page as insecure on address bar

Categories

(Firefox :: Address Bar, enhancement, P3)

60 Branch
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1562881

People

(Reporter: lolipopplus, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: parity-chrome)

since now HTTPS pages are mainstream, we are surely to address HTTP as insecure with some visual indicators.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
See Also: → 1067293
Chrome is going to do this
Keywords: parity-chrome
Since 61 is already released, I think 62 should be the goal so it wouldn't be too far from Chrome. 
Perhaps use the "Not Secure" text on 63, too?

Firefox can't wait too long after Chrome, otherwise it is going to be the "browser where pages are safe".
Chrome has this in its 68 already. I wonder when this can happen for Firefox. If Firefox falls too far, it just becomes much less competitive
I would like to see this in Firefox, too, but I doubt this statement is true. Firefox won't become "muss less competitive" because it doesn't mark HTTP pages as insecure. By the way: I already see users complain about this feature in Chrome. I still think it's the right thing to do but I don't see any relation between this feature and competitiveness, that doesn't make much sense.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.