Bookmark folders with same name get synced in the wrong subtree

RESOLVED DUPLICATE of bug 1305563

Status

()

defect
RESOLVED DUPLICATE of bug 1305563
Last year
Last year

People

(Reporter: frz.dev, Unassigned)

Tracking

60 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180516032328

Steps to reproduce:

I have bookmarks organized in hierarchical folders, often with sub-folders having the same name.
 
For example:
Web
  |- ToDo
Work
  |- ToDo


Actual results:

During sync, folders with same name got mixed somehow.

For the previous example:
Web
  |- ToDo
  |- ToDo
Work
  |-


Expected results:

Bookmarks should be synced with the same tree structure as before:
For the previous example:
Web
  |- ToDo
Work
  |- ToDo
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180523100147

Hi frz.dev,

I tried to reproduce the issue after syncing together Windows 10 x64, Ubuntu 16.04 and also Android on Firefox Nightly 62.0a1, Firefox Beta 61.0b7 and Firefox Release 60.0.1.

I followed the same tree structure of the folders and it was synced accordingly on all devices. However, this was a simplified method which did not work in my case (perhaps it requires a more complex bookmarks tree structure). Bookmark syncing seem to have known issues similar to this one, here are some of them that might be related: Bug 812348, Bug 1124369.

Can you please retest the issue using exactly the same steps on latest Nightly using a new clean Firefox profile (https://goo.gl/AWo6h8) as well as safe mode (https://goo.gl/AR5o9d) to eliminate custom settings as a possible cause?
I’m also assigning this issue to a component in order to involve the development team in a proper review. 

Thank you.
Component: Untriaged → Sync
Flags: needinfo?(frz.dev)
Hi Timea, thanks for your answer.

I'll try to reproduce the bug as you said.

Meanwhile, it's worth mentioning that I often use more than one instance of FF on different devices, which could influence the bug somehow. However, yesterday I worked from home with just one instance, and again today at work I had some folders moved to the wrong subtree.
Also, I usually work on different subfolder from different instances (e.g. I add a bookmark to the MyWork/ToDo from my work PC, and another bookmark to MyWeb/Todo from my laptop).
This is just to add some details, in case it might help to reproduce the bug.

BTW, I'm using Firefox 60.0.1 on three different devices (Ubuntu 16.04 x64 on PC and on laptop, and Windows 10 x64).

Thanks,
F.
Flags: needinfo?(frz.dev)
Hi frz.dev, thanks for the report!

This is a case of Sync's deduping gone awry. It'll unfortunately make a mess if you have two folders with the same name in different subtrees :-( See bug 1323333, and all the bugs it depends on, for more context, and other cases where we'll get it wrong.

The good news is, we're working on a better engine that should handle this correctly. If you have time and inclination to help us out, it would be awesome if you could follow the instructions in https://blog.nightly.mozilla.org/2018/05/14/deep-dive-new-bookmark-sync-in-nightly/#h.wahcrun4vjbu to turn on the new engine on Firefox 61+ (Beta and Nightly only; it's not in 60), and let us know how it works for you. We'll hopefully enable it for everyone by default later this year.

Thanks!
Hi Kit,
thanks for the explanation. It's great to hear that you're working on a solution.

I also notices that the bug seems to only affetc "low-level" subfolders.
For instance, I have a lot of folders named "Blogs", but they don't get messed.
It seems that it's just a problem with first-level subfolders.
The other option is that they get messed only when I add some bookmarks.
I guess I'll have to do some tries.

I'll try to do what you told whenever I have some free time :)

Thanks
(In reply to frz.dev from comment #4)
> I also notices that the bug seems to only affetc "low-level" subfolders.
> For instance, I have a lot of folders named "Blogs", but they don't get
> messed.
> It seems that it's just a problem with first-level subfolders.

Yup. :-( Current deduping uses the parent folder title...if you have a "Blogs" folder in your toolbar, and another one in your menu, the folders won't smush (since the parent titles are "Bookmarks Toolbar" and "Bookmarks Menu"), but their contents may...or may not, depending on which one we see first locally, and which bookmarks are changed when downloading. It's not very predictable, sadly.

New deduping takes the hierarchy into account, and shouldn't do things like this; one of the tests sets up a tree similar to the one you described. :-) I'll go ahead and close this out as a dupe of bug 1305563, but I'd still be super interested in hearing if it works for you, whenever you have some free time. Thanks again for taking the time to investigate and file the bug!
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1305563
You need to log in before you can comment on or make changes to this bug.