Closed Bug 1462642 Opened Last year Closed Last year

[Wayland] eglChooseConfig fails on Wayland due to missing pbuffer support on Mesa EGL implementation

Categories

(Core :: Graphics, enhancement, P2)

All
Linux
enhancement

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Follow up from https://bugzilla.mozilla.org/show_bug.cgi?id=1438144#c6

We need to implement framebuffer objects (FBOs) instead of pbuffers.
Comment on attachment 8979894 [details]
Bug 1462642 - [Wayland/EGL] Use dummy wl_egl_window instead of PBuffer,

https://reviewboard.mozilla.org/r/246094/#review252280
Attachment #8979894 - Flags: review?(lsalzman) → review+
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/9250f12dd57c
[Wayland/EGL] Use dummy wl_egl_window instead of PBuffer, r=lsalzman
Duplicate of this bug: 1455571
https://hg.mozilla.org/mozilla-central/rev/9250f12dd57c
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.