Closed Bug 1462736 Opened Last year Closed Last year

Turn on telemetry, endpoint pref, and button_type option for AS Router experiment

Categories

(Firefox :: Messaging System, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 62
Iteration:
64.1 - Sep 14
Tracking Status
firefox61 --- verified
firefox62 --- verified

People

(Reporter: k88hudson, Assigned: k88hudson)

References

(Blocks 1 open bug)

Details

User Story

https://github.com/mozilla/activity-stream/compare/firefox-61b5...firefox-61b7

Attachments

(1 file)

We need to uplift the following commits for our intended snippets/AS router experiment:

https://github.com/mozilla/activity-stream/commit/d1f54414fd0e5c1cc831ce7780e8446e70dbfd19
https://github.com/mozilla/activity-stream/commit/a5cfac930ada2529f6bcc8944c71954933b11674

which turn on telemetry telemetry, supports an endpoint pref, and a button type.

These patches have already landed in nightly as part of a previous export.
Attachment #8977084 - Flags: review?(edilee)
Comment on attachment 8977084 [details]
Bug 1462736 - Turn on telemetry, endpoint pref, and button_type option for AS Router experiment

https://reviewboard.mozilla.org/r/245158/#review251186

Looks good. Make sure to push to activity-stream branch, so the commit in version matches up.

::: browser/extensions/activity-stream/install.rdf.in:11
(Diff revision 1)
>    <Description about="urn:mozilla:install-manifest">
>      <em:id>activity-stream@mozilla.org</em:id>
>      <em:type>2</em:type>
>      <em:bootstrap>true</em:bootstrap>
>      <em:unpack>false</em:unpack>
> -    <em:version>2018.05.11.1144-66b23ff4</em:version>
> +    <em:version>2018.05.18.1094-b5f16f3d</em:version>

Is this a local commit revision on the firefox-61 branch? Could you push that to activity-stream repository so it'll match up?
Attachment #8977084 - Flags: review?(edilee) → review+
Oh.. it looks like the repository does know b5f16f3d8959e9483919399543474126fa9da497 exists.. but.. isn't part of firefox-61 branch… ?
User Story: (updated)
Depends on: 1460119
Looks like github didn't like how I merged your branch, and it made a new revision:

https://github.com/mozilla/activity-stream/commit/00de1d9cf1b73ff1084507ce0fd6b0d984da1c34
User Story: (updated)
Comment on attachment 8977084 [details]
Bug 1462736 - Turn on telemetry, endpoint pref, and button_type option for AS Router experiment

https://reviewboard.mozilla.org/r/245158/#review251194
Comment on attachment 8977084 [details]
Bug 1462736 - Turn on telemetry, endpoint pref, and button_type option for AS Router experiment

https://reviewboard.mozilla.org/r/245158/#review251186

> Is this a local commit revision on the firefox-61 branch? Could you push that to activity-stream repository so it'll match up?

If you re-export with latest firefox-61, it should end up as 00de1d9c
Comment on attachment 8977084 [details]
Bug 1462736 - Turn on telemetry, endpoint pref, and button_type option for AS Router experiment

Approval Request Comment
[Feature/Bug causing the regression]: Turn on telemetry/endpoint pref for AS Router Snippets Experiment
[User impact if declined]: We will be unable to collect data for our scheduled experiment
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: We will be doing a PI request for the experiment as soon as this lands
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: it is behind a pref / has been previously tested in nightly
[String changes made/needed]: none
Attachment #8977084 - Flags: approval-mozilla-beta?
Depends on: 1462427
Flags: qe-verify+
Target Milestone: --- → Firefox 62
Comment on attachment 8977084 [details]
Bug 1462736 - Turn on telemetry, endpoint pref, and button_type option for AS Router experiment

Enables Telemetry needed to support Activity Stream experiments scheduled for Beta. Approved for 61.0b7.
Attachment #8977084 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
User Story: (updated)
Blocks: 1464019
I have verified that the issue is no longer reproducible on Firefox Beta starting with 61.0b7 on Windows 10 x64, Mac 10.13.4 and Arch Linux x64. We changed the Button from Snippets to a Link, enabled telemetry for all associated actions to Snippets and added the "browser.newtabpage.activity-stream.asrouter.snippetsUrl" pref.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → Messaging System
Iteration: --- → 64.1 - Sep 14
You need to log in before you can comment on or make changes to this bug.