Java plugin doesn't work anymore after upgrade

RESOLVED INVALID

Status

Core Graveyard
Java-Implemented Plugins
RESOLVED INVALID
16 years ago
6 years ago

People

(Reporter: nemo, Assigned: Igor Kushnirskiy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
after an upgrade (and nothing else) of Mozilla from RC1 to RC2 (mandrake
packages) Java doesn't work anymore. this is the console output when I enter
"mozilla" on the command line :

[/usr/lib/mozilla/plugins/rpnp.so: undefined symbol: __pure_virtual]
LoadPlugin: failed to initialize shared library
/usr/lib/mozilla/plugins/libnpp.so [/usr/lib/mozilla/plugins/libnpp.so:
undefined symbol: event__7QObjectP6QEvent]
LoadPlugin: failed to initialize shared library
/usr/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so
[/usr/java/j2sdk1.4.0/jre/plugin/i386/ns610/libjavaplugin_oji140.so: undefined
symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

By, Henri

Comment 1

16 years ago
Doesn't look like a mozilla bug.

Seems the realplayer plugin suddenly has unresolved symbols as well?
Are you sure the rpm's you downloaded were made for your own version of the
mandrake distribution?

WFM, testing with a current trunk cvs build, linux: no unresolved symbols in
Java or 
(Reporter)

Comment 2

16 years ago
I 'm sure of it, it's a cooker package finishing with mdk and I have an mdk8.2.
So it should work (rc1 worked well)
Henri.

Comment 3

16 years ago
Mandrake comments like this about their mozilla-1.0-0.rc2.4mdk.i586.html package:

- Java support is BROKEN (because of gcc 3.1 switch).. No need to complain..
- Plugins support is broken for plugins compiled with gcc < 3.x.y 

So if you remove the plugins, this should work. Neither realplayer or Java is
compiled with gcc3. This is not a Mozilla bug. Resolving as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
err.. that was the mozilla-1.0-0.rc2.4mdk.i586.rpm package of course.
Information at rpmfind.

Comment 5

16 years ago
if there's a fix for bug 124006 (gcc 3.0) it might help this.
Not sure it covers gcc 3.1.
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.