Closed Bug 1462836 Opened Last year Closed 11 months ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /fetch/api/redirect/redirect-count.any.html | Redirect 308 21 times - Test timed out

Categories

(Core :: DOM: Core & HTML, defect, P5)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: ytausky)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled][wptsync upstream error])

Attachments

(2 files, 6 obsolete files)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=179274617&repo=autoland

https://queue.taskcluster.net/v1/task/DAefIv37TimHFqxToQpjiQ/runs/0/artifacts/public/logs/live_backing.log

[task 2018-05-18T23:17:52.706Z] 23:17:52     INFO - TEST-START | /fetch/api/redirect/redirect-count.any.html
[task 2018-05-18T23:18:02.887Z] 23:18:02     INFO - 
[task 2018-05-18T23:18:02.887Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 301 20 times 
[task 2018-05-18T23:18:02.887Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 301 21 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 302 20 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 302 21 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 303 20 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 303 21 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 307 20 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 307 21 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 308 20 times 
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-UNEXPECTED-TIMEOUT | /fetch/api/redirect/redirect-count.any.html | Redirect 308 21 times - Test timed out
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-UNEXPECTED-TIMEOUT | /fetch/api/redirect/redirect-count.any.html | expected OK
[task 2018-05-18T23:18:02.890Z] 23:18:02     INFO - TEST-INFO took 10182ms
[task 2018-05-18T23:18:02.911Z] 23:18:02     INFO - PID 4025 | 1526685482906	Marionette	INFO	Stopped listening on port 2828
[task 2018-05-18T23:18:03.073Z] 23:18:03     INFO - PID 4025 | *** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: telemetry_modules_ping
[task 2018-05-18T23:18:03.404Z] 23:18:03     INFO - Browser exited with return code 0
[task 2018-05-18T23:18:03.405Z] 23:18:03  WARNING - u'runner_teardown': ()
[task 2018-05-18T23:18:03.422Z] 23:18:03     INFO - Setting up ssl
[task 2018-05-18T23:18:03.458Z] 23:18:03     INFO - certutil | 
[task 2018-05-18T23:18:03.494Z] 23:18:03     INFO - certutil | 
[task 2018-05-18T23:18:03.516Z] 23:18:03     INFO - certutil | 
[task 2018-05-18T23:18:03.516Z] 23:18:03     INFO - Certificate Nickname                                         Trust Attributes
[task 2018-05-18T23:18:03.517Z] 23:18:03     INFO -                                                              SSL,S/MIME,JAR/XPI
[task 2018-05-18T23:18:03.517Z] 23:18:03     INFO - 
[task 2018-05-18T23:18:03.517Z] 23:18:03     INFO - web-platform-tests                                           CT,, 
[task 2018-05-18T23:18:03.517Z] 23:18:03     INFO - 
[task 2018-05-18T23:18:03.542Z] 23:18:03     INFO - Application command: /builds/worker/workspace/build/application/firefox/firefox --marionette about:blank -profile /tmp/tmpCx43mE.mozrunner
[task 2018-05-18T23:18:03.562Z] 23:18:03     INFO - Starting runner
[task 2018-05-18T23:18:03.826Z] 23:18:03     INFO - PID 4203 | 1526685483821	addons.xpi-utils	WARN	Error: Synchronously loading the add-ons database (resource://gre/modules/addons/XPIDatabase.jsm:1392:17) JS Stack trace: syncLoadDB@XPIDatabase.jsm:1392:17
[task 2018-05-18T23:18:03.827Z] 23:18:03     INFO - PID 4203 | checkForChanges@XPIProvider.jsm:2376:9
[task 2018-05-18T23:18:03.828Z] 23:18:03     INFO - PID 4203 | startup@XPIProvider.jsm:1909:25
[task 2018-05-18T23:18:03.829Z] 23:18:03     INFO - PID 4203 | callProvider@AddonManager.jsm:205:12
[task 2018-05-18T23:18:03.829Z] 23:18:03     INFO - PID 4203 | _startProvider@AddonManager.jsm:653:5
[task 2018-05-18T23:18:03.829Z] 23:18:03     INFO - PID 4203 | startup@AddonManager.jsm:812:9
[task 2018-05-18T23:18:03.831Z] 23:18:03     INFO - PID 4203 | startup@AddonManager.jsm:2864:5
[task 2018-05-18T23:18:03.831Z] 23:18:03     INFO - PID 4203 | observe@addonManager.js:66:9
[task 2018-05-18T23:18:05.817Z] 23:18:05     INFO - PID 4203 | 1526685485813	Marionette	INFO	Listening on port 2828
Over the past 24 hours there are 30 failures on this bug. These happen on linux32, linux64, linux64-qr.

Here is the most recent log example: https://treeherder.mozilla.org/logviewer.html#?job_id=179390336&repo=autoland&lineNumber=2106

[task 2018-05-20T11:45:23.358Z] 11:45:23     INFO - TEST-START | /fetch/api/redirect/redirect-count.any.html
[task 2018-05-20T11:45:33.524Z] 11:45:33     INFO - 
[task 2018-05-20T11:45:33.524Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 301 20 times 
[task 2018-05-20T11:45:33.524Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 301 21 times 
[task 2018-05-20T11:45:33.525Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 302 20 times 
[task 2018-05-20T11:45:33.526Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 302 21 times 
[task 2018-05-20T11:45:33.527Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 303 20 times 
[task 2018-05-20T11:45:33.529Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 303 21 times 
[task 2018-05-20T11:45:33.529Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 307 20 times 
[task 2018-05-20T11:45:33.529Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 307 21 times 
[task 2018-05-20T11:45:33.530Z] 11:45:33     INFO - TEST-PASS | /fetch/api/redirect/redirect-count.any.html | Redirect 308 20 times 
[task 2018-05-20T11:45:33.530Z] 11:45:33     INFO - TEST-UNEXPECTED-TIMEOUT | /fetch/api/redirect/redirect-count.any.html | Redirect 308 21 times - Test timed out
[task 2018-05-20T11:45:33.530Z] 11:45:33     INFO - TEST-UNEXPECTED-TIMEOUT | /fetch/api/redirect/redirect-count.any.html | expected OK
[task 2018-05-20T11:45:33.530Z] 11:45:33     INFO - TEST-INFO took 10164ms
[task 2018-05-20T11:45:33.550Z] 11:45:33     INFO - PID 4024 | 1526816733544	Marionette	INFO	Stopped listening on port 2828
[task 2018-05-20T11:45:33.741Z] 11:45:33     INFO - PID 4024 | *** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: telemetry_modules_ping
[task 2018-05-20T11:45:34.040Z] 11:45:34     INFO - Browser exited with return code 0
[task 2018-05-20T11:45:34.041Z] 11:45:34  WARNING - u'runner_teardown': ()
Flags: needinfo?(overholt)
:gbrown, please take a look at comment 3. thank you.
Flags: needinfo?(gbrown)
Fail could be caused by https://hg.mozilla.org/integration/mozilla-inbound/rev/6bb3c37d2bdb
I see that redirect-count.any.html was added in https://hg.mozilla.org/integration/mozilla-inbound/rev/9debd5451211 but there the test didn`t fail
:annevk, can you please take a look?
Flags: needinfo?(annevk)
It seems extremely unlikely that either of those changesets are responsible. They change the formatting of the test, but the tests existed long before those changes too.
Flags: needinfo?(annevk)
My usual go-to person for these types of issues is bkelly.
Flags: needinfo?(overholt) → needinfo?(bkelly)
See Also: → 1463107
with 284 failures in the last week, and bug 1463107 having a high daily failure rate now, I we should disable this asap to help green our trees up.

this fails >50% of the time on linux:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=opt-web-platform-tests-e10s-5%20linux&tochange=26800d5aaf70be800a1a14c858e09ea54b21edeb&fromchange=7f19d8ef14c4d6c55764e8fa9c89421a244b0e57&selectedJob=179987479

:ebalazs_, can you add a new .ini file to disable this, this would be a redirect-count.any.js.ini file:
testing/web-platform/meta/fetch/api/redirect/redirect-count.any.js.ini
Flags: needinfo?(gbrown) → needinfo?(ebalazs)
Duplicate of this bug: 1463107
Attached patch bug1462836.patch (obsolete) — Splinter Review
Attachment #8980641 - Flags: review?(jmaher)
Comment on attachment 8980641 [details] [diff] [review]
bug1462836.patch

Review of attachment 8980641 [details] [diff] [review]:
-----------------------------------------------------------------

this file is created as:
testing/web-platform/tests/fetch/api/redirect/redirect-count.any.js.ini 

but it should be in the meta folder:
testing/web-platform/meta/fetch/api/redirect/redirect-count.any.js.ini 

you can do a hg mv:
hg mv testing/web-platform/tests/fetch/api/redirect/redirect-count.any.js.ini testing/web-platform/meta/fetch/api/redirect/redirect-count.any.js.ini

::: testing/web-platform/tests/fetch/api/redirect/redirect-count.any.js.ini
@@ +1,3 @@
> +[redirect-count.any.js]
> +disabled:
> +    if (os == "linux"): https://bugzilla.mozilla.org/show_bug.cgi?id=1462836

nit: 2 space indent, not 4
Attachment #8980641 - Flags: review?(jmaher) → review-
Attached patch bug1462836.patch (obsolete) — Splinter Review
attempt #2
Attachment #8980641 - Attachment is obsolete: true
Attachment #8980666 - Flags: review?(jmaher)
Comment on attachment 8980666 [details] [diff] [review]
bug1462836.patch

Review of attachment 8980666 [details] [diff] [review]:
-----------------------------------------------------------------

looks great
Attachment #8980666 - Flags: review?(jmaher) → review+
Keywords: checkin-needed
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Flags: needinfo?(ebalazs)
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d2aecae5a71
Disabled redirect-count.any.js test on Linux. r=jmaher
Keywords: checkin-needed
:jmaher all wpt failures were https://bugzilla.mozilla.org/show_bug.cgi?id=1400716, they did not fail on fetch/api/redirect/redirect-count.any.html
oh, this is so confusing, the .js file generates a .html file, so we need to make a js.ini file which references the .html file as the test case.

So instead of:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d2aecae5a71#l1.5

+[redirect-count.any.js]

we need:
+[redirect-count.any.html]


I really wish this were more straightforward.

Henrietta, could you help find someone on shift to disable this?
Flags: needinfo?(jmaher) → needinfo?(hmaior)
Whiteboard: [stockwell disabled] → [stockwell disable-recommended]
Assignee: nobody → aciure
Attachment #8980666 - Attachment is obsolete: true
Attachment #8981308 - Flags: review?(jmaher)
Flags: needinfo?(hmaior)
Comment on attachment 8981308 [details] [diff] [review]
Bug 1462836 - Disabled redirect-count.any.js test on Linux

Review of attachment 8981308 [details] [diff] [review]:
-----------------------------------------------------------------

this looks pretty good.  As I was wrong before, I have to admit I could be wrong again.
Attachment #8981308 - Flags: review?(jmaher) → review+
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f469e464de5f
Disabled redirect-count.any.js test on Linux. r=jmaher
Keywords: checkin-needed
Backed out 1 changesets (bug 1462836) for "Test harness output was not a valid structured log message" on a CLOSED TREE

Problematic push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=f469e464de5f345022a42268164d702379062299&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified
Failure: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified&selectedJob=180701964
Log: https://treeherder.mozilla.org/logviewer.html#?job_id=180701964&repo=mozilla-inbound&lineNumber=551
Backout: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=dfbe62f4ab7535c1388586e309bd01e339ef3142&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified

12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL - Traceback (most recent call last):
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\runtests.py", line 16, in <module>
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     rv = wptrunner.main()
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptrunner.py", line 334, in main
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     return start(**kwargs)
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptrunner.py", line 321, in start
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     return not run_tests(**kwargs)
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptrunner.py", line 166, in run_tests
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     **kwargs)
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptrunner.py", line 74, in get_loader
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     skip_timeout=kwargs["skip_timeout"])
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\testloader.py", line 495, in __init__
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     self._load_tests()
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\testloader.py", line 561, in _load_tests
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     for test_path, test_type, test in self.iter_tests():
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\testloader.py", line 546, in iter_tests
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     inherit_metadata, test_metadata = self.load_metadata(manifest_file, metadata_path, test_path)
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\testloader.py", line 529, in load_metadata
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     metadata_path, test_path, test_manifest.url_base, self.run_info)
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\manifestexpected.py", line 274, in get_manifest
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     url_base=url_base)
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptmanifest\backends\static.py", line 220, in compile
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     return compile_ast(parse(stream),
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptmanifest\parser.py", line 746, in parse
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     return p.parse(stream)
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptmanifest\parser.py", line 509, in parse
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     self.consume()
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptmanifest\parser.py", line 514, in consume
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     self.token = self.token_generator.next()
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptmanifest\parser.py", line 101, in tokenize
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     for token in tokens:
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -   File "Z:\task_1527597046\build\tests\web-platform\tests\tools\wptrunner\wptrunner\wptmanifest\parser.py", line 183, in key_state
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL -     raise ParseError(self.filename, self.line_number, "Space in key name")
12:41:50 CRITICAL - Test harness output was not a valid structured log message: 
12:41:50 CRITICAL - wptrunner.wptmanifest.parser.ParseError: Space in key name: Z:\task_1527597046\build\tests\web-platform\meta\fetch\api\redirect\redirect-count.any.js.ini line 1
12:41:51    ERROR - Return code: 1
12:41:51    ERROR - No checks run.
12:41:51    ERROR - No suite end message was emitted by this harness.
12:41:51 CRITICAL - # TBPL FAILURE #
Flags: needinfo?(overholt)
somehow what was checked in was a diff file, not what the diff resulted in.

I tested this locally and the spacing is key, the diff (if it was applied) would have failed as 'disabled' was not indented.  This is what should be there:
[redirect-count.any.js]
  disabled:
    if (os == "linux"): https://bugzilla.mozilla.org/show_bug.cgi?id=1462836

Eliza, could you pick this up (or get a fellow sheriff to help out)?
Flags: needinfo?(overholt)
Flags: needinfo?(ebalazs)
Flags: needinfo?(bkelly)
Attachment #8981308 - Attachment is obsolete: true
Flags: needinfo?(ebalazs)
Attachment #8981447 - Flags: review?(jmaher)
Comment on attachment 8981447 [details] [diff] [review]
Disabled redirect-count.any.js test on Linux

this is an empty patch, can you try again?
Attachment #8981447 - Flags: review?(jmaher)
Did the requested changes. Hope this works better.
Attachment #8981447 - Attachment is obsolete: true
Attachment #8981471 - Flags: review?(jmaher)
Comment on attachment 8981471 [details] [diff] [review]
Disabled redirect-count.any.js test on Linux

Review of attachment 8981471 [details] [diff] [review]:
-----------------------------------------------------------------

thanks!
Attachment #8981471 - Flags: review?(jmaher) → review+
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b400e931ba82
Disable /fetch/api/redirect/redirect-count.any.html for frequent timeouts. r=jmaher
Keywords: checkin-needed
:jgraham, how can we skip this test on linux?  it has been very difficult to figure out how to do this.  The patch we landed today I ran locally while adjusting it for |if os==windows| and it didn't run the tests when run locally.  So I am confused how to test this locally and what to do in order to stop the failures.
Flags: needinfo?(jmaher) → needinfo?(james)
Don't you need to put the change in "redirect-count.any.html.ini"?  The commit message has the right name, but the ini file is referencing the "any.js" instead.  And it probably didn't run locally because you tried to run "any.js" instead of "any.html".
The ini path is based on the source file. The heading is based on the test id. So the right fix looks like:

diff --git a/testing/web-platform/meta/fetch/api/redirect/redirect-count.any.js.ini b/testing/web-platform/meta/fetch/api/redirect/redirect-count.any.js.ini
new file mode 100644
index 000000000000..fdecb3f07f5c
--- /dev/null
+++ b/testing/web-platform/meta/fetch/api/redirect/redirect-count.any.js.ini
@@ -0,0 +1,3 @@
+[redirect-count.any.html]
+  disabled:
+    if os == "linux": https://bugzilla.mozilla.org/show_bug.cgi?id=1462836

So the patch here is nearly right, you just need to s/.js/.html/ in the file for it to work.
Flags: needinfo?(james)
thanks :jgraham!
Attached patch bug_1462836.patch (obsolete) — Splinter Review
Attachment #8981471 - Attachment is obsolete: true
Attachment #8981841 - Flags: review?(jmaher)
Comment on attachment 8981841 [details] [diff] [review]
bug_1462836.patch

Review of attachment 8981841 [details] [diff] [review]:
-----------------------------------------------------------------

how come this is a new file?  it should be an edit to an existing file
Attachment #8981841 - Flags: review?(jmaher) → review-
Attachment #8981841 - Attachment is obsolete: true
Attachment #8981964 - Flags: review?(jmaher)
Comment on attachment 8981964 [details] [diff] [review]
bug_1462836.patch

Review of attachment 8981964 [details] [diff] [review]:
-----------------------------------------------------------------

great!
Attachment #8981964 - Flags: review?(jmaher) → review+
Pushed by dluca@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9276f5991369
disable redirect-count.any.html on linux. r=jmaher
Keywords: checkin-needed
Priority: -- → P5
Assignee: aciure → ytausky
Status: NEW → ASSIGNED
The test has since been moved and I couldn't find recent reports of it failing. Maybe we should close this bug? Same goes for bug 1463107.
The failures were reported on a test ending with .html, whereas the current version is a .js file. If I understand the .ini mechanism correctly, that file has no effect since the .html files are gone. It's a good idea to delete it, though.
Never mind, :asuth pointed out my mistake. Sorry for the bugmail spam.
Duplicate of this bug: 1463107
This test runs multiple testcases, so sometimes 10 seconds are not enough for
all of them to finish. This commit bumps the timeout to 60 seconds and reenabled
the test on Linux.
Comment on attachment 9013325 [details]
Bug 1462836: Extend timeout of long testsuite

Andrew Sutherland [:asuth] has approved the revision.
Attachment #9013325 - Flags: review+
Pushed by bugmail@asutherland.org:
https://hg.mozilla.org/integration/autoland/rev/9a685b824b88
Extend timeout of long testsuite r=asuth
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a1cfc8fd44ee
Backed out changeset 9a685b824b88 for ES lint failure
Pushed by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84c7bfa3a0f5
Extend timeout of long testsuite CLOSED TREE r=asuth
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/13305 for changes under testing/web-platform/tests
Whiteboard: [stockwell disabled] → [stockwell disabled][wptsync upstream]
Upstream PR was closed without merging
I'm not sure what happened here, but it looks like the CI failure was due to the linter failing to run, and the patch is now in the tree.
Flags: needinfo?(ytausky)
Upstream PR merged
Can't merge web-platform-tests PR due to failing upstream checks:
Github PR https://github.com/web-platform-tests/wpt/pull/13305
* Taskcluster (pull_request) (https://tools.taskcluster.net/task-group-inspector/#/FT9kGQ6tRf6138UY_OSymg)
Whiteboard: [stockwell disabled][wptsync upstream] → [stockwell disabled][wptsync upstream error]
Everything is committed and no failures, resolving as fixed.
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
QA Contact: overholt
Resolution: --- → FIXED
QA Contact: overholt
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.