javascript repeated entry on open menu item in collapsing tree

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: john russell, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020522
BuildID:    2002052208

my page uses Morten's tree menu which is a collapsing folder
style in javascript.  with the build i am now using the currently
open page is double or more printed as is its icon.  This did not 
occur with my previous mozilla build of a month ago and the menu 
works well with kmeleon, netscape6, netscape 4, opera 6 and 
msie6... i think something that was introduced in the javascript
engine in the last month is causing this peculiarity... 
sorry to have to report it but best caught now eh! 

Reproducible: Always
Steps to Reproduce:
1.visit http://home.cogeco.ca/~ve3ll
2.click on any page in left sidebar
3. note the replicated display... 

Actual Results:  replicated icons and text lines

Expected Results:  single icon and text

started with this build  but my last one 
that worked was a month old !!!
(Reporter)

Comment 1

16 years ago
after testing a second time and achieving a C++ runtime error
R6025 -- pure virtual function call  I backed out to RC2
(build 2002051006).  the good news is that the problem does
not exist in RC2.... so it cuts the time frame when the 
bug was introduced....  hope others can duplicate, isolate and squash! 
john in niagara VE3LL@RAC.CA

Comment 2

16 years ago
Gee, this site WORKSFORME using Mozilla trunk build 2002052008 WinNT.
Not getting any errors in the JavaScript Console, and no items in 
the tree menu are getting doubled.

I see the attribution in view-source:http://home.cogeco.ca/~ve3ll/code.htm

               // Morten's JavaScript Tree Menu
               // version 2.3.1, dated 2002-02-02
               // http://www.treemenu.com/


I went to http://www.treemenu.com/ with the same Mozilla build,
and there I could see a major doubling problem just by mousing over
the tree items; you don't even have to click them. Still no errors
in the JavaScript Console.

If this bug can be reproduced, it's going to be some problem involving 
browser-level code: such as DOM Level 0, DOM CSS, or Event Handling.
I don't see any JavaScript Engine bug being responsible for it.

For the time being, reassigning to DOM Level 0 and cc'ing self
in case I can be of help with the JavaScript Debugger on this.
But I can't reproduce the bug - at least not at the given site, 
http://home.cogeco.ca/~ve3ll
Assignee: rogerl → jst
Component: JavaScript Engine → DOM Level 0
QA Contact: pschwartau → desale
I cannot reproduce this problem in a current trunk linux build.  John, is this
still an issue?
(Reporter)

Comment 4

16 years ago
This is no longer an issue with me as I have changed 
menuing system to CoolMenus to get away from frames!
I don't know whether it is Javascript coding or Java
engine problem so maybe it is best to file as resolved
 and move on to other stuff.







OK.  Since it also works on the http://www.treemenu.com/ site... ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.