Tools > Options > General subdialog is shown. Clicking other subdiaglogs/tabs is ineffective.

RESOLVED FIXED in Thunderbird 62.0

Status

defect
RESOLVED FIXED
11 months ago
11 months ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({regression})

Trunk
Thunderbird 62.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
+++ This bug was initially created as a clone of Bug #1460721 +++

With 2018-05-15 and 2018-05-18 nightly on windows 7 in new profile, the General options tab is shown but cicking other subdiaglogs/tabs is ineffective. Nightly 2018-05-08 works.  So I assume a regression of bug 1457021.

I started 2018-05-19 nightly (not in safe mode, not in new profile) and results are similar, but INCONSISTENT. For example when I first opened options I got a subdialog that was not General. My next click brought up the General subdialog and was stuck there.

But clicking any pref in the displayed dialog work and are changes are saved
(Reporter)

Comment 1

11 months ago
Also, nightly frequently crashes - crashed even in a new profile.  Someone else mentioned this to me in the last couple days, don't remember where.
Summary: No Font list in Prefs > Display - TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/pref-window/test-font-chooser.js | test-font-chooser.js → General options subdialog is shown. Cicking other subdiaglogs/tabs is ineffective.
(Reporter)

Updated

11 months ago
See Also: → 1462918
(Reporter)

Updated

11 months ago
Duplicate of this bug: 1462922
I played a bit. When I go directly to the prefs menuitem and open the prefs, they work without a issue. But when I stop at the "Add-on Options" menuitem (not clicking) and then go to the prefs and open them, I see your behavior.

Actually I have no extension installed to show in the "Add-on Options". I can't say if there would be a difference when one would be shown.

I see no different errors in the console when stopping or not stopping on the "Add-on Options" item and then opening the prefs.
(Reporter)

Comment 4

11 months ago
I typically go in through the menu bar using keyboard alt+T+O+O etc. 

I swear sometimes I see nothing in error console. This time I saw

 [Show/hide message details.] document.l10n is undefined fontbuilder.js:46
buildFontList
chrome://mozapps/content/preferences/fontbuilder.js:46:9
next self-hosted:1219:9 

which is nothing new
Summary: General options subdialog is shown. Cicking other subdiaglogs/tabs is ineffective. → General options subdialog is shown. Clicking other subdiaglogs/tabs is ineffective.

Comment 5

11 months ago
document.l10n is undefined fontbuilder.js:46 is mentioned in bug 1462922 comment #0. So this would make this a duplicate of bug 1460721. Aceman, can you please get bug 1460721 fixed, so we can see whether this bug and bug 1462923 get fixed as well.
Flags: needinfo?(acelists)
The good news is that with bug 1455649 `document.l10n` is always gonna be available. You'll just need to provide a `<linkset/>` with the l10n resources to make it localized.
(Reporter)

Updated

11 months ago
Duplicate of this bug: 1463548
(Reporter)

Updated

11 months ago
Depends on: 1460721

Comment 8

11 months ago
Wayne, do you still see this?
In today's trunk I can switch pref panels correctly.
(Yes the document.l10n error is there, but that is for bug 1460721).
Flags: needinfo?(acelists) → needinfo?(vseerror)

Comment 9

11 months ago
I can't change options. I am using Daily 62.0a1 (2018-05-26) (64-bit). Cheers.
(Reporter)

Comment 10

11 months ago
(In reply to acescos from comment #9)
> I can't change options. I am using Daily 62.0a1 (2018-05-26) (64-bit).

ditto. I'm on win7
Flags: needinfo?(vseerror)

Comment 11

11 months ago
(In reply to :aceman from comment #8)
> In today's trunk I can switch pref panels correctly.
> (Yes the document.l10n error is there, but that is for bug 1460721).

TB 62.0a1 (2018-05-26) (64-bit)

Initially it is working, but that it did always (at least this end), but after a while (or perhaps some interaction with TB, e.g. opening/closing add-ons) it does not anymore. The console is reporting at that point

undefined mailWindowOverlay.js:3764:5
initAddonPrefsMenu
chrome://messenger/content/mailWindowOverlay.js:3764:5
onpopupshowing
chrome://messenger/content/messenger.xul:1:1
TypeError: window.top.openWebLinkIn is not a function[Learn More] viewSourceUtils.js:77:5 

Afterwards TB is not exiting properly and hangs in memory. I keep on submittign crash reports, in case anybody is investigating those.

Comment 12

11 months ago
vtol, that actually looks like bug 1462923, including the TB hanging in memory. I can see that when trying to open the "Addon Options".

But the bug here is about Tools->Options, not addon prefs.

Comment 13

11 months ago
(In reply to :aceman from comment #12)
> But the bug here is about Tools->Options, not addon prefs.

Sure, I know. It just seems/feels like there is a correlation, at least this end.

First I thought it this bug) was time triggered, i.e. when having started TB the option panel works fine but then after a while it does not anymore. But what would be the time trigger?

So, having kept TB open for a while without opening Add-ons (mind you not Add-on Options) the issue does not occur and TB is also shutting down without hanging/crashing.

But soon after having opened Add-ons the option panel still opens but none of its categories is accessible. And TB hangs on shut down and crashes (those crash reports I keep on sending).

Comment 14

11 months ago
comment #3 seems to indicate such correlation with Add-ons too

Comment 15

11 months ago
With bug #1462923 patched (62.0a1 (2018-05-28) (64-bit)) this bug appears to be gone as well - Option accessible with no issues. TB is also not hanging/crashing anymore on exit, the only exception been during the update from b2018-05-27 to b2018-05-28.

Comment 16

11 months ago
Thanks, fixed the unselectable options for me!
(Reporter)

Comment 17

11 months ago
> Sure, I know. It just seems/feels like there is a correlation, at least this end.

It would seem, but apparently not, because https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=4109d3b43113b7dc6607dfcb2878d384bc64c6a4 from bug 1462923 comment 19 did not help me (the reporter), using a clean profile and my production profile. 

So this correlates to bug 1460721 as Jorg.  I still see

document.l10n is undefined fontbuilder.js:46
buildFontList
chrome://mozapps/content/preferences/fontbuilder.js:46:9
next self-hosted:1219:9
Summary: General options subdialog is shown. Clicking other subdiaglogs/tabs is ineffective. → Tools > Options > General subdialog is shown. Clicking other subdiaglogs/tabs is ineffective.

Comment 18

11 months ago
(In reply to Wayne Mery (:wsmwk) from comment #17)
> It would seem, but apparently not, because
> https://treeherder.mozilla.org/#/jobs?repo=try-comm-
> central&revision=4109d3b43113b7dc6607dfcb2878d384bc64c6a4 from bug 1462923
> comment 19 did not help me (the reporter), using a clean profile and my
> production profile. 
> 
> So this correlates to bug 1460721 as Jorg.  I still see
> 
> document.l10n is undefined fontbuilder.js:46
> buildFontList
> chrome://mozapps/content/preferences/fontbuilder.js:46:9
> next self-hosted:1219:9

Don't see how but could the OS play into it? Your box seem to be on WIN 7 (32-bit/64-bit?) whilst mine is on WIN 10 1709 b6299.461 (64-bit). As per comment #15 that patch solved this bug this end.

document.l10n still showing up in the console but does not appear to have an impact on this issue (least this end), like mentioned in comment #8.

Would it be worthwhile to uninstall TB and reinstall fresh and try with a clean profile again?

Comment 19

11 months ago
(In reply to gene smith from comment #16)
> Thanks, fixed the unselectable options for me!

Actually, not fixed. I think it's random. Every few tb starts the icon select at the top of "Daily Preferences" screen has no effect and it is stuck at "Daily Start Page". Then restart tb and can select them again. Haven't tried a clean profile.

Comment 20

11 months ago
Should be fixed by the following:
- Bug 1462923: Fixed add-on options.
- Bug 1465061: Removed stand-alone options window (which was the one that was broken, no?)
- Bug 1460721: Landed patch to fix font selection.
Bug 1465061 and bug 1460721 are still open since we need to re-establish some tests to work on the in-content prefs, but there are no functional issues left.

If there's still a problem, please reopen.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 62.0
You need to log in before you can comment on or make changes to this bug.