Closed Bug 1462955 Opened 2 years ago Closed 2 years ago

text of addons from about:addons page gets drawn in the tabbar

Categories

(Core :: Graphics: WebRender, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- fix-optional

People

(Reporter: mayankleoboy1, Assigned: kvark)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180519100118

Steps to reproduce:

1. Use nightly. enable webrender. REstart
2. Install bugzillaJS from https://addons.mozilla.org/en-US/firefox/addon/bugzillajs/?src=userprofile

3. Go to about:addons. Then open the bugzillaJS config/info page from there
4. The page has lots of text and settings
5. Scroll down the page. (IF needed, reduce the height of the browser window so that scrolling is possible)


Actual results:

text gets drawn in the tab-bar


Expected results:

not so
Component: General → Graphics: WebRender
Attached file aboutsupport.txt
Batch updating status flags based on WR schedule - please adjust if needed.
Hmm, I can't seem to reproduce this. Are you still seeing this? Does it happen if you disable your browser theme?
Priority: -- → P1
(In reply to Alexis Beingessner [:Gankro] from comment #3)
> Hmm, I can't seem to reproduce this. Are you still seeing this? Does it
> happen if you disable your browser theme?


I can still reproduce this, even if I disable the browser theme.
Attached image Capture.PNG
The whole page's text doesnt appear in the text bar.

Only the text below "changes take effect on teh next load of bugzilla" will appear in the tab-bar. So you might have to reduce the vertical height of the browser window, such that that part of ht text will become scrollable.
This looks vaguely like some text not being clipped in that area that should be... Not entirely sure why.
I can reproduce this. Note that this also requires a theme installed, you can use the "Web Browser Renaissance" one from the customize panel.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #7)
> I can reproduce this. Note that this also requires a theme installed, you
> can use the "Web Browser Renaissance" one from the customize panel.

I dont have any theme installed, and I can still reproduce it. (unless you mean the Windows desktop theme)
Ah, you're right. I can see it without a theme as well. It's just harder to see because only the checkbox backgrounds are obviously visible; the text is black on dark-blue so harder to see.
Assignee: nobody → kvark
This should be fixed with the next WR update as the fix has landed upstream.
Depends on: 1476636
Depends on: 1477400
No longer depends on: 1477400
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.