Closed Bug 1463024 Opened 4 years ago Closed 4 years ago

login/password losing focus once switched tabs

Categories

(Toolkit :: Password Manager, defect)

61 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1228802

People

(Reporter: karlcow, Unassigned)

References

()

Details

This is a spin-off of webcompat issue https://webcompat.com/issues/16938
It doesn't seem to be a webcompat issue but more something related to the UI and its default state.

Firefox::General for the lack of a better idea where this should go. :) Sorry


Steps to reproduce
1. With Firefox Nightly 62.0a1 (2018-05-17) (64-bit)
2. Go to https://hackerforums.co/index.php
3. Click on login (a pop up appears and the cursor is focused on login automatically)
4. Click on another tab
5. Come back to your hackerforums tab

Expected: 
The cursor is still focused in the login area. (like Chrome and Safari)

Actual:
The login input has lost its focus. User has to click in the area to regain the focus.
(In reply to Karl Dubost :karlcow from comment #0)

> Firefox::General for the lack of a better idea where this should go. :) Sorry

Please use Firefox::Untriaged when you're not sure of a better place to file. ::General is intended more for things that, correctly, do not have a more appropriate bucket.

MattN: moving this to pwmgr, but maybe this is just more of a DOM thing?
Component: General → Password Manager
Product: Firefox → Toolkit
This actually is webcompat bug: It's https://github.com/twbs/bootstrap/issues/18365 which was worked around in bootstrap in https://github.com/twbs/bootstrap/pull/18639 and filed as bug 1228802 for Gecko to fix.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228802
You need to log in before you can comment on or make changes to this bug.