If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FIX POS]{inc}Weird margin changing after first load.

RESOLVED DUPLICATE of bug 90270

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 90270
16 years ago
15 years ago

People

(Reporter: dylang, Assigned: Marc Attinasi)

Tracking

({css2, qawanted})

Trunk
Future
x86
All
css2, qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
This is one of those weird style bugs that crops up from time to time.  In this
case, the calendar on the left side is first rendered properly with a margin
between its top and the top of the web window.  However, on reload or clicking
any of those links, Mozilla re-renders this page without the margin.

It's very weird because nothing changes on the server side between the two
reloads: Mozilla is deciding to not render that margin past the first time. 
Perhaps some variable is (incorrectly) re-initialized in the code?
Looks like an incremental reflow problem.
Status: UNCONFIRMED → NEW
Component: Style System → Layout
Ever confirmed: true
Summary: Weird margin changing after first load. → {inc}Weird margin changing after first load.

Comment 2

16 years ago
The calendar appears to be `position: fixed', which would make me think this
isn't a margin problem. Regardless, I'm not seeing the problem on a trunk build...
Should be easy to see by resizing the page after it loads.
Mmm, it's probably something with the fun
auto-offset-at-the-static-position-position code.
->Layout
Assignee: dbaron → attinasi
Keywords: css2
QA Contact: ian → petersen
Summary: {inc}Weird margin changing after first load. → [FIX POS]{inc}Weird margin changing after first load.
Yeah, that code basically sets "position: fixed" and then sets top, bottom, and 
height all to auto.  Almost certainly a dup of bug 90270
Depends on: 90270

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 7

15 years ago
Apparently WorksForMe using FizzillaCFM/2002071208. Adding qawanted; could use a
minimized testcase.
Keywords: qawanted
(Reporter)

Comment 8

15 years ago
Here are some screen shots illustrating the behaviour:

First loaded (not the spacing between the top of the window viewport and the
left-hand nav bar -- the navbar top is also slightly corrupted because of a bug
WRT changing fonts and properly redrawing everything which I haven't filed):
http://web.thock.com/mozilla/moz-fixpos-inc-1.png

After pressing reload, the margin "disapears" and never returns unless I surf in
(rather than press reload/go button).  Different code paths yield different
stylesheet results, it seems:
http://web.thock.com/mozilla/moz-fixpos-inc-2.png

I'll see what I can do about a minimal test case.

Comment 9

15 years ago
Layout of the site has changed. However, behaviour reported here seems to
persist: see http://inoshiro.com/changelog/?date=2002.08.01 and
http://inoshiro.com/changelog/?date=2002.07.01. Working on minimal test case.

Comment 10

15 years ago
Behaviour seen when page is/isn't large enough for the scroll bars to appear.
Attaching test cases.

Comment 11

15 years ago
Created attachment 106892 [details]
test case

Page small, thus scroll bars to not appear. No margin above "box".

Comment 12

15 years ago
Created attachment 106893 [details]
test case to compare with previous submission

Page bigger, to cause scroll bars to appear. Now space/margin appears above
"box".
Yeah, that testcase is fixed by the patch in bug 90270
dup

*** This bug has been marked as a duplicate of 90270 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
No longer depends on: 90270
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.