Closed Bug 1463050 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 11019 - Worker: Add service worker interception tests for module loading on dedicated workers

Categories

(Core :: DOM: Service Workers, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: wptsync, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 11019 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/w3c/web-platform-tests/pull/11019
Details from upstream follow.

Hiroki Nakagawa <nhiroki@chromium.org> wrote:
>  Worker: Add service worker interception tests for module loading on dedicated workers
>  
>  This CL adds both web-platform-tests and conventional layout tests because the
>  current Chrome implementation is not spec-compatible in terms of service worker
>  scope matcing with dedicated workers (see https://crbug.com/731599). The layout
>  tests will be removed after the issue is fixed.
>  
>  Bug: 680046
>  Change-Id: If214bd2f647ee5e7257ae134a870cf1e4ddac608
>  Reviewed-on: https://chromium-review.googlesource.com/1059979
>  WPT-Export-Revision: 8f7ffa8fd31fccfad7f0bac266c554b02200ba4f
>  
>  
>
Component: web-platform-tests → DOM: Workers
Product: Testing → Core
Looks like we are failing this.  I'll take a look a bit later.
Flags: needinfo?(bkelly)
Oh yea.  We don't have modules in workers yet.  Nevermind.
Flags: needinfo?(bkelly)
Component: DOM: Workers → DOM: Service Workers
Result changes from PR not available.
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2bed6abb0825
[wpt PR 11019] - Worker: Add service worker interception tests for module loading on dedicated workers, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/ec6c88fb9bb8
[wpt PR 11019] - Update wpt metadata, a=testonly
https://hg.mozilla.org/mozilla-central/rev/2bed6abb0825
https://hg.mozilla.org/mozilla-central/rev/ec6c88fb9bb8
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.