Instrument inspection of "Edit HTML" in Inspector with event telemetry

RESOLVED FIXED in Firefox 62

Status

P2
normal
RESOLVED FIXED
8 months ago
6 months ago

People

(Reporter: miker, Assigned: miker)

Tracking

(Blocks: 1 bug)

57 Branch
Firefox 62
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(2 attachments)

Comment hidden (empty)
Created attachment 8979195 [details]
data-review.txt

Events.yaml:
devtools.main:
  edit_html:
    objects: ["inspector"],
    bug_numbers: [1463080]
    notification_emails: ["dev-developer-tools@lists.mozilla.org", "hkirschner@mozilla.com"]
    record_in_processes: ["main"]
    description: User is editing HTML via the context menu item in the markup view.
    release_channel_collection: opt-out
    expiry_version: never
    extra_keys:
      made_changes: Indicates whether changes were made.
      time_open: The amount of time in ms that the HTML editor was open.

Usage:
this.telemetry.recordEvent("devtools.main", "edit_html", "inspector", null, {
      made_changes: true,
      time_open: 10000
});
Attachment #8979195 - Flags: review?(andrei.br92)
Attachment #8979195 - Flags: review?(andrei.br92) → review?(francois)
Comment hidden (mozreview-request)
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Comment on attachment 8979195 [details]
data-review.txt

1) Is there or will there be **documentation** that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes, Events.yaml.

2) Is there a control mechanism that allows the user to turn the data collection on and off?

Yes, telemetry setting.

3) If the request is for permanent data collection, is there someone who will monitor the data over time?**

Yes, Harald Kirschner.

4) Using the **[category system of data types](https://wiki.mozilla.org/Firefox/Data_Collection)** on the Mozilla wiki, what collection type of data do the requested measurements fall under?  **

Category 2

5) Is the data collection request for default-on or default-off?

Default on, all channels.

6) Does the instrumentation include the addition of **any *new* identifiers** (whether anonymous or otherwise; e.g., username, random IDs, etc.  See the appendix for more details)?

No.

7) Is the data collection covered by the existing Firefox privacy notice?

Yes.

8) Does there need to be a check-in in the future to determine whether to renew the data?

No, permanent.
Attachment #8979195 - Flags: review?(francois) → review+

Comment 4

8 months ago
mozreview-review
Comment on attachment 8980090 [details]
Bug 1463080 - Instrument inspection of "Edit HTML" in Inspector with event telemetry

https://reviewboard.mozilla.org/r/246254/#review253516

Looks good!
Attachment #8980090 - Flags: review?(ystartsev) → review+

Comment 5

8 months ago
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d2e3e0b253d2
Instrument inspection of "Edit HTML" in Inspector with event telemetry r=yulia

Comment 6

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d2e3e0b253d2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
status-firefox62: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62

Updated

7 months ago
Product: Firefox → DevTools
Duplicate of this bug: 1479390
You need to log in before you can comment on or make changes to this bug.