Instrument inspection of JS execution in the Web Console with event telemetry

RESOLVED FIXED in Firefox 62

Status

defect
P2
normal
RESOLVED FIXED
a year ago
3 months ago

People

(Reporter: miker, Assigned: miker)

Tracking

(Blocks 1 bug)

57 Branch
Firefox 62
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(2 attachments)

No description provided.
Comment hidden (obsolete)
Attachment #8979200 - Flags: review?(andrei.br92) → review?(francois)
Please add the number of lines as a key.
(In reply to :Harald Kirschner :digitarald from comment #2)
> Please add the number of lines as a key.

So that would be:

Events.yaml:
devtools.main:
  execute_js:
    objects: ["webconsole"],
    bug_numbers: [1463083]
    notification_emails: ["dev-developer-tools@lists.mozilla.org", "hkirschner@mozilla.com"]
    record_in_processes: ["main"]
    description: User has executed some JS in the Web Console.
    release_channel_collection: opt-out
    expiry_version: never
    extra_keys:
      lines: The number of lines contained in the command.

Usage:
this.telemetry.recordEvent("devtools.main", "execute_js", "webconsole", null, {
  lines: "1"
});
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Depends on: 1463083
Comment on attachment 8979200 [details]
data-review.txt

1) Is there or will there be **documentation** that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes, Events.yaml.

2) Is there a control mechanism that allows the user to turn the data collection on and off?

Yes, telemetry setting.

3) If the request is for permanent data collection, is there someone who will monitor the data over time?**

Yes, Harald Kirschner.

4) Using the **[category system of data types](https://wiki.mozilla.org/Firefox/Data_Collection)** on the Mozilla wiki, what collection type of data do the requested measurements fall under?  **

Category 2

5) Is the data collection request for default-on or default-off?

Default on, all channels.

6) Does the instrumentation include the addition of **any *new* identifiers** (whether anonymous or otherwise; e.g., username, random IDs, etc.  See the appendix for more details)?

No.

7) Is the data collection covered by the existing Firefox privacy notice?

Yes.

8) Does there need to be a check-in in the future to determine whether to renew the data?

No, permanent.
Attachment #8979200 - Flags: review?(francois) → review+

Comment 6

a year ago
mozreview-review
Comment on attachment 8980327 [details]
Bug 1463087 - Instrument inspection of JS execution in the Web Console with event telemetry

https://reviewboard.mozilla.org/r/246476/#review253536

Looks good
Attachment #8980327 - Flags: review?(ystartsev) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s bc7f622839f48b5efd3b42bec8dab7aece50ffa5 -d d2e3e0b253d2: rebasing 465565:bc7f622839f4 "Bug 1463087 - Instrument inspection of JS execution in the Web Console with event telemetry r=yulia" (tip)
merging devtools/client/webconsole/components/JSTerm.js
merging toolkit/components/telemetry/Events.yaml
warning: conflicts while merging toolkit/components/telemetry/Events.yaml! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Comment hidden (mozreview-request)

Comment 9

a year ago
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b2cbe2403283
Instrument inspection of JS execution in the Web Console with event telemetry r=yulia

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b2cbe2403283
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62

Updated

a year ago
Product: Firefox → DevTools
Duplicate of this bug: 1477322
ni? Nicolas for prioritization.
Flags: needinfo?(nchevobbe)
What's left to do here Harald ?
Flags: needinfo?(nchevobbe) → needinfo?(hkirschner)
Sorry, bad ni?. Work here is done.
Flags: needinfo?(hkirschner)
Duplicate of this bug: 1413008
You need to log in before you can comment on or make changes to this bug.