Improper formatting of background or text spacing

RESOLVED WONTFIX

Status

()

Core
Layout: Tables
P3
normal
RESOLVED WONTFIX
15 years ago
8 years ago

People

(Reporter: Greg Harrison, Unassigned)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    20020510

The text which is supposed to fall between the purple bars overlaps the right
purple bar.  This problem is not present in IE 6.  This problem also affects the
IRIX build.  It is an active server page, so this may be an IE-formatted page. 

Reproducible: Always
Steps to Reproduce:
1. Open page
2. Look 
3.

Expected Results:  Text fit properly.

Comment 1

15 years ago
WFM on a current trunk CVS build and on 7.0b1 - Linux
confirming with win2k build 20020522..

-> Layout
Assignee: Matti → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: imajes-qa → petersen

Comment 3

15 years ago
Changing priority to P3.
Priority: -- → P3

Updated

15 years ago
Target Milestone: --- → Future
Tables.  That middle cell is 48px wider than specified...
Assignee: attinasi → table
Component: Layout → Layout: Tables
OS: Windows 2000 → All
Priority: P3 → --
QA Contact: cpetersen0953 → madhur
Hardware: PC → All
Target Milestone: Future → ---

Updated

14 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 5

13 years ago
This bug is still present on Mozilla 1.7b and Firefox .8:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Haven't tried Firefox .9 yet.

Comment 6

13 years ago
A reduced testcase would be good here.
Keywords: qawanted

Comment 7

13 years ago
Still a bug with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

The bug is caused by the long line of hyphens at the bottom of this page. The
length of that line exceeds the width of the table cell. If you shorten the
number of hyphens, the page renders the same on IE and Firefox. IE breaks the
line into two, whereas Firefox extends the entire table cell. I'll upload a very
brief testcase that shows the difference. 

Comment 8

13 years ago
Created attachment 158342 [details]
Table Cell testcase

Shows the difference between IE and Mozilla. 

PS: Bernd I saw your blog, I could use a Gmail account.

Comment 9

13 years ago
I think this is an IE bug, I haven't seen a lot of them in table layout but this
seems to be one. We render this identical to opera and NN4.8

Updated

13 years ago
Keywords: qawanted → testcase

Comment 10

13 years ago
*** Bug 269539 has been marked as a duplicate of this bug. ***

Comment 11

8 years ago
what IE (also IE8) does it limits the width of the text to the specified 400px for the table cell, while the table is expanded to 700px what is specified as a table width. No other browser does this. I don't see any point in implementing this quirk. As times tells there aren't a lot pages relying on this quirk, we would otherwise have a bunch of dupes.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.