Remove the "wizard-base" binding and import the "wizard.css" file as a document stylesheet

RESOLVED FIXED in Firefox 63

Status

()

task
P1
normal
RESOLVED FIXED
Last year
22 days ago

People

(Reporter: bgrins, Assigned: Paolo)

Tracking

(Blocks 1 bug)

unspecified
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

Last year
wizard-base is only used to load wizard.css, which has some pretty simple rules.

This may actually end up being a better candidate for global.css since we'd generally prefer to make these document styles if there's not a big risk for regressions. Especially since it does seem to have a few !important rules so we need to be careful with Bug 1457907 if we want to migrate to components.css.
Assignee

Updated

Last year
Blocks: 1470830
Summary: Remove wizard-base binding and import wizard.css in global.css (or components.css) → Remove the "wizard-base" binding and import the "wizard.css" file as a document stylesheet
Reporter

Comment 2

Last year
mozreview-review
Comment on attachment 8990312 [details]
Bug 1463320 - Remove the "wizard-base" binding and import the "wizard.css" file as a document stylesheet.

https://reviewboard.mozilla.org/r/255348/#review262216
Attachment #8990312 - Flags: review?(bgrinstead) → review+
Assignee

Updated

Last year
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Priority: P5 → P1
Assignee

Comment 4

Last year
The test failures are from the previous patch, and I've tested the import wizard manually.

Comment 5

Last year
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/17ee04ad9a57
Remove the "wizard-base" binding and import the "wizard.css" file as a document stylesheet. r=bgrins
Backed out changeset 17ee04ad9a57 (bug 1463320) for frequent failures on /extensions/test/browser/browser_list.js on a CLOSED TREE

Backout link: https://hg.mozilla.org/integration/mozilla-inbound/rev/e139fa8d93ef9a4a181e2c4fb027e62cc487726d

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=17ee04ad9a577f131971c7a9a28dc80622438337

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=187189171&repo=mozilla-inbound&lineNumber=27397

Log snippet: 

09:50:35     INFO - TEST-START | toolkit/mozapps/extensions/test/browser/browser_list.js
09:50:35     INFO - GECKO(1123) | 1531155035071	addons.manager	DEBUG	Starting provider: <unnamed-provider>
09:50:35     INFO - GECKO(1123) | 1531155035071	addons.manager	DEBUG	Registering shutdown blocker for <unnamed-provider>
09:50:35     INFO - GECKO(1123) | 1531155035072	addons.manager	DEBUG	Provider finished startup: <unnamed-provider>
09:50:35     INFO - GECKO(1123) | ++DOCSHELL 0x12643d000 == 2 [pid = 1127] [id = {09b96d85-6b4f-7b43-b789-f84172765d80}]
09:50:35     INFO - GECKO(1123) | ++DOMWINDOW == 10 (0x127dfd600) [pid = 1127] [serial = 128] [outer = 0x0]
09:50:35     INFO - GECKO(1123) | ++DOMWINDOW == 11 (0x127d3ac00) [pid = 1127] [serial = 129] [outer = 0x127dfd600]
09:50:35     INFO - GECKO(1123) | ++DOMWINDOW == 12 (0x127d3e400) [pid = 1127] [serial = 130] [outer = 0x127dfd600]
09:50:35     INFO - GECKO(1123) | --DOMWINDOW == 11 (0x127dfac00) [pid = 1127] [serial = 120] [outer = 0x0] [url = about:blank]
09:50:35     INFO - GECKO(1123) | --DOMWINDOW == 10 (0x127df9400) [pid = 1127] [serial = 118] [outer = 0x0] [url = about:blank]
09:50:35     INFO - GECKO(1123) | ++DOCSHELL 0x122628000 == 13 [pid = 1123] [id = {2f48f371-8190-6f4c-8927-6a92a1f7e5e1}]
09:50:35     INFO - GECKO(1123) | ++DOMWINDOW == 39 (0x110060a00) [pid = 1123] [serial = 836] [outer = 0x0]
09:50:35     INFO - GECKO(1123) | ++DOMWINDOW == 40 (0x12fd7f000) [pid = 1123] [serial = 837] [outer = 0x110060a00]
09:50:35     INFO - GECKO(1123) | ++DOMWINDOW == 41 (0x1250cb400) [pid = 1123] [serial = 838] [outer = 0x110060a00]
09:50:35     INFO - GECKO(1123) | [Parent 1123, Main Thread] WARNING: NS_ENSURE_TRUE(aIndex < mLength) failed: file /builds/worker/workspace/build/src/docshell/shistory/nsSHistory.cpp, line 1241
09:50:35     INFO - GECKO(1123) | ++DOMWINDOW == 42 (0x12f404800) [pid = 1123] [serial = 839] [outer = 0x110060a00]
09:50:36     INFO - GECKO(1123) | --DOCSHELL 0x12f4a1800 == 12 [pid = 1123] [id = {de620f2a-80a1-ab4d-93a8-c96a116d71df}]
09:50:36     INFO - GECKO(1123) | --DOCSHELL 0x125903800 == 11 [pid = 1123] [id = {190d16de-4f81-d346-a03b-231eaedf5aed}]
09:50:36     INFO - GECKO(1123) | --DOCSHELL 0x11ce0c800 == 10 [pid = 1123] [id = {381fea87-4e97-ec4e-9f25-32a91cca641f}]
09:50:36     INFO - GECKO(1123) | --DOMWINDOW == 41 (0x124943000) [pid = 1123] [serial = 813] [outer = 0x0] [url = about:blank]
09:50:36     INFO - GECKO(1123) | --DOMWINDOW == 40 (0x124940800) [pid = 1123] [serial = 809] [outer = 0x0] [url = about:blank]
09:50:36     INFO - GECKO(1123) | --DOMWINDOW == 39 (0x124940c00) [pid = 1123] [serial = 810] [outer = 0x0] [url = about:blank]
09:50:36     INFO - GECKO(1123) | ++DOCSHELL 0x11ce0c800 == 11 [pid = 1123] [id = {32f93251-8d49-b047-95e9-2d51064c56fa}]
09:50:36     INFO - GECKO(1123) | ++DOMWINDOW == 40 (0x121e95600) [pid = 1123] [serial = 840] [outer = 0x0]
09:50:36     INFO - GECKO(1123) | ++DOMWINDOW == 41 (0x124941400) [pid = 1123] [serial = 841] [outer = 0x121e95600]
09:50:36     INFO - GECKO(1123) | [Parent 1123, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file /builds/worker/workspace/build/src/dom/base/nsContentUtils.cpp, line 4043
09:50:37     INFO - GECKO(1123) | [Parent 1123, Main Thread] WARNING: NS_ENSURE_TRUE(aSecondURI) failed: file /builds/worker/workspace/build/src/dom/base/ThirdPartyUtil.cpp, line 98
09:50:37     INFO - GECKO(1123) | ++DOMWINDOW == 42 (0x125059400) [pid = 1123] [serial = 842] [outer = 0x121e95600]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 9 (0x11fc58000) [pid = 1127] [serial = 119] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 8 (0x126452400) [pid = 1127] [serial = 122] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 7 (0x12644f400) [pid = 1127] [serial = 124] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 41 (0x1258cf400) [pid = 1123] [serial = 812] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 40 (0x124d1d800) [pid = 1123] [serial = 826] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 39 (0x121e98400) [pid = 1123] [serial = 819] [outer = 0x0] [url = http://127.0.0.1:8888/extensions-dummy/discoveryURL]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 38 (0x1258d0400) [pid = 1123] [serial = 815] [outer = 0x0] [url = about:addons]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 37 (0x125077200) [pid = 1123] [serial = 808] [outer = 0x0] [url = about:addons]
09:50:39     INFO - GECKO(1123) | --DOCSHELL 0x111d28000 == 0 [pid = 1128] [id = {d1472b12-9fac-394d-ab9a-2326b3773fae}]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 6 (0x118c38400) [pid = 1126] [serial = 163] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 5 (0x11f453400) [pid = 1126] [serial = 161] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 4 (0x11f44f000) [pid = 1126] [serial = 164] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOCSHELL 0x122f4a800 == 1 [pid = 1126] [id = {62ff2960-f277-774f-ad9e-c8c525531a1a}]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 2 (0x122d43200) [pid = 1128] [serial = 67] [outer = 0x0] [url = about:blank]
09:50:39     INFO - GECKO(1123) | --DOMWINDOW == 3 (0x122fd1200) [pid = 1126] [serial = 165] [outer = 0x0] [url = about:blank]
09:50:40     INFO - TEST-INFO | started process screencapture
09:50:40     INFO - TEST-INFO | screencapture: exit 0
09:50:40     INFO - <snipped 156 output lines - if you need more context, please use SimpleTest.requestCompleteLog() in your test>
09:50:40     INFO - Buffered messages logged at 09:50:39
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error message should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error message should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error link should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error link text should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error link should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Pending message should be hidden - 
09:50:40     INFO - Addon 10
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Test add-on 10 - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Name should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Tooltip name should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Preferences button should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Enable button should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Disable button should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Remove button should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning message should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning message should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning link should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning link text should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning link should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error message should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error link should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Pending message should be hidden - 
09:50:40     INFO - Addon 11
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Test add-on 11 - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Name should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Tooltip name should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Preferences button should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Enable button should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Disable button should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Remove button should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning message should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning message should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning link should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error message should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error link should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Pending message should be hidden - 
09:50:40     INFO - Filter for disabled unsigned extensions shouldn't appear because signing checks are off
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Button for showing disabled unsigned extensions should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Button for showing all extensions should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Signing info UI should be hidden - 
09:50:40     INFO - Leaving test bound 
09:50:40     INFO - Entering test bound 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Should not get category when manager window is not loaded - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Should not open category when manager window is not loaded - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Should not check visible state when manager window is not loaded - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Category should be visible if attempting to open it - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Should not get category when manager window is not loaded - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Should not open category when manager window is not loaded - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Should not check visible state when manager window is not loaded - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Category should be visible if attempting to open it - 
09:50:40     INFO - Buffered messages logged at 09:50:40
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Should be the right number of add-ons installed - 
09:50:40     INFO - Addon 6
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Test add-on 6 - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Name should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Tooltip name should be correct - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Disabled postfix should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Preferences button should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Enable button should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Disable button should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Remove button should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning message should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Warning link should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error message should be visible - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Error link should be hidden - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Pending message should be hidden - 
09:50:40     INFO - Enabling
09:50:40     INFO - TEST-PASS | toolkit/mozapps/extensions/test/browser/browser_list.js | Element should not be null, when checking visibility - 
09:50:40     INFO - Buffered messages finished
09:50:40     INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/extensions/test/browser/browser_list.js | Disabled postfix should be hidden -
Flags: needinfo?(paolo.mozmail)

Comment 7

Last year
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a34a6f54da75
Remove the "wizard-base" binding and import the "wizard.css" file as a document stylesheet. r=bgrins
Assignee

Comment 8

Last year
Removing the "#header" rule which was a leftover in the Mac stylesheet should fix this.
Flags: needinfo?(paolo.mozmail)

Comment 9

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/a34a6f54da75
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63

Updated

22 days ago
Type: enhancement → task
You need to log in before you can comment on or make changes to this bug.