Closed Bug 1463381 Opened 4 years ago Closed 4 years ago

All of the Pocket cards icon statuses look disabled on Nightly and Beta

Categories

(Firefox :: New Tab Page, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 62
Iteration:
62.2 - Jun 4
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox60 --- unaffected
firefox61 --- wontfix
firefox62 --- verified
firefox63 --- unaffected

People

(Reporter: cmuresan, Assigned: rrosario)

References

Details

(Keywords: regression)

Attachments

(3 files)

[Affected versions]:
- Nightly 62.0a1 Build ID  20180521100109
- Beta 61.0b6

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have a profile with a lot of history so that all of the sections are populated

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites and open a new tab.
2. Observe the color of the icons from the card's statuses (Circle for Visited, Star for Bookmarked, Pocket for Saved to Pocket, Bolt for Trending).

[Expected results]:
- The icons have a dark shade of gray.

[Actual results]:
- The icons have a light gray color.

[Regression window]:
14:10.60 INFO: Last good revision: 89cf5ea77822c475f560b79eb2e50a9bb3a0d557
14:10.60 INFO: First bad revision: 4183020e7017569bdf931c7630dd907ed01ef8ee
14:10.60 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=89cf5ea77822c475f560b79eb2e50a9bb3a0d557&tochange=4183020e7017569bdf931c7630dd907ed01ef8ee

Looks like bug 1454780 caused this issue.

[Notes]:
- The issue is not reproducible on Release 60.
- Attached a screenshot of the issue.
Assignee: nobody → rrosario
Iteration: --- → 62.2 - Jun 4
Priority: -- → P2
See Also: → 1459289
This only applies to Pocket cards now.
Summary: All of the Highlight cards icon statuses look disabled on Nightly and Beta → All of the Pocket cards icon statuses look disabled on Nightly and Beta
Design (Bryan Bell) says to change that text and icon color to --newtab-text-secondary-color. It currently is --newtab-text-tertiary-color. easy peasy
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/09c33324726081d2cd4386827b73ede013113390
Fix Bug 1463381 - change color of context text and icon on Pocket cards

https://github.com/mozilla/activity-stream/commit/18eb3a6ba81e5e903e7ff8f953a2c14529f500c1
Merge pull request #4187 from rlr/Bug1463381/type-text-color

Fix Bug 1463381 - change color of context text and icon on Pocket cards
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/2058fce5467a88b5a0934f8f33786f067ef87e27
fix(styles): remove unused var(--newtab-text-tertiary-color) (#4193)

Followup Bug 1463381
Blocks: 1466971
This issue is partially fixed, now all the icons from the "Recommended by Pocket" area, have the correct shade of gray. However, the "clock" icon (for the visited websites) from the "Highlights" area still has a lighter gray color.
Considering the above I will reopen this issue.

Verified on Windows 10 x64, Mac 10.13 and Arch Linux, with the latest Nightly (62.0a1 - 20180607220114) installed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/8f005384cd9b58caf445675f6e32861fe53c3214
fix(styles): Remove history fill override (#4199)

Followup Bug 1463381 - fix history icon fill color (compact cards)
Blocks: 1467858
https://hg.mozilla.org/mozilla-central/rev/ac40929aa54d
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
I have verified this issue on the latest version of Nightly (63.0a1 Build ID - 20180703100028) and Firefox Beta (62.0b4) on Windows 10 x64, Arch Linux x64 and Mac 10.13.3. Now all the card's icons have the same color.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.